Invisible cursor - bad css handling

RESOLVED INVALID

Status

()

Core
Layout: View Rendering
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: Emmanuel Engelhart, Assigned: roc)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>

<head>
    <title>test</title>
</head>

<body>

	<form method="post" action="test.html">

    <div style="left : 0px; top: 0px; position: fixed; height: 52px; width: 100%; ">

	<div>
		<div style="top: 100px; position: absolute; " >
           test
		</div>
	</div>

    </div>

	<div style="top: 0px; height: 55px;">
		&nbsp;
	</div>


    <input name="test" type="text" />

	</form>

</body>

</html>

Reproducible: Always

Steps to Reproduce:
1. Load the test code
2. Click on the text input field, and type something.
3. Take a look :-(

Actual Results:  
-The cursor is always invisible.
-Doesn't work under a recent version of firefox under windows too.

Expected Results:  
- Makes the cursor visible

Comment 1

13 years ago
Created attachment 183287 [details]
Slightly modified test case

Your fixed position <div> covers the input box, so it doesn't get mouse
events (or a cursor).

I don't know why it is still possible to type into it; nor whether this is
the expected behaviour; but it is not inxeplicable.
Not a CSS issue.  This is basically bug 167801....
Component: Style System (CSS) → Layout: View Rendering
Depends on: 167801
Assignee: dbaron → roc
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 4

12 years ago
dup per comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 5

12 years ago
fixing resolution - sorry for the spam.

*** This bug has been marked as a duplicate of 167801 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
No longer depends on: 167801
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

12 years ago
The bug still exists under 1.5.0.7
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

12 years ago
Emmanuel Engelhart, why are you reopening this bug? bz, a core developer, said in comment 2 that this is a dup of bug 167801. If you read that bug, you'll see that it has been fixed, but of course not in 1.5.x, nor will it be fixed in the upcoming 2.0, but only on trunk, i.e. 3.0. So, testing with 1.5.0.7 is irrelevant, please test against a trunk build as mentioned in bug 167801 comment 56.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

12 years ago
Sorry. I'm confused.
You need to log in before you can comment on or make changes to this bug.