Closed Bug 293751 Opened 15 years ago Closed 15 years ago

event object not available inside onevent code

Categories

(Core :: SVG, defect)

x86
Windows 98
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: simon.place, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050417 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050417 Firefox/1.0+

the event object, used to get the details of an event, does not exist inside
inline on-event code.
example:

this correctly shows shift status:
<h1 onclick="this.textContent=event.shiftKey">SVG 3D Test</h1>  


but you get error in SVG:
<text  onclick="this.textContent=event.shiftKey;">Hello, out there</text>
"Error: event is not defined"

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Does it work in XML (in general)?
This is due to the SVG WG calling the event object "evt".
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.