dot (period) in toolbar keyword search confuses engine

RESOLVED DUPLICATE of bug 261608

Status

()

RESOLVED DUPLICATE of bug 261608
14 years ago
14 years ago

People

(Reporter: subs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

If I use the toolbar search for a keyword containing a dot, such as "firefox
1.0.3" - the search mechanism treats it like a url containing a space, and
returns the error "The URL is not valid and cannot be loaded"

Reproducible: Always

Steps to Reproduce:
see above
Actual Results:  
see above

Expected Results:  
search for "firefox 1.0.3"

Comment 1

14 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050514
Firefox/1.0+
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050610
Firefox/1.0+ ID:2005061007

WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
reopening just to mark as duplicate of bug 261608.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

*** This bug has been marked as a duplicate of 261608 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.