Show All Bookmarks should remember that last state of the bookmark tree, and selected container

RESOLVED FIXED in Camino0.9

Status

defect
--
major
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: craig.upton, Assigned: sfraser_bugs)

Tracking

({fixed1.8})

unspecified
Camino0.9
PowerPC
macOS

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050509 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050509 Camino/0.8+

Show All Bookmarks should remember that last state of the bookmark tree.
Example., When I close the Show All Bookmarks tab after selecting a bookmark a
few levels deep in the bookmark tree, I should be able to go back into Show All
Bookmarks and still have the tree expanded to the last state I left it in rather
than collapsed as it currently is. It should function the same as the History
currently does.

Reproducible: Always

Steps to Reproduce:
1. Select Show All Bookmarks from the Bookmarks menu
2. Expand a few folders to 
3. Close the Show All Bookmarks tab
4. Open Show All Bookmarks again and you will see the bookmark tree is collapsed
and not in the last state that you left it.

Actual Results:  
Bookmark tree is collapsed

Expected Results:  
Remembered the state of the bookmark tree before you closed the Show All
Bookmarks tab.
-> smfr

not sure if this is a dupe. should we put this on the 09 list or leave it for 1.0?
Assignee: pinkerton → sfraser_bugs
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Comment 2

14 years ago
*** Bug 291906 has been marked as a duplicate of this bug. ***
Assignee

Comment 3

14 years ago
*** Bug 298368 has been marked as a duplicate of this bug. ***
Target Milestone: --- → Camino1.0

Comment 4

14 years ago
Also, when switching to bookmarks it always selects the "Bookmarks Menu" group.
 It would be nice that if you were in the "Bookmarks Bar" group that it would
remember that.  It looks like the this bug was fixed for Bookmarks Menu and
History, but NOT for Bookmarks Bar.
Assignee

Comment 5

14 years ago
Fixed.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Target Milestone: Camino1.0 → Camino0.9

Comment 6

14 years ago
I still see this bug in the 2005080108 and 205080208 builds... I select "Show
all bookmarks", it defaults to the bookmark bar group, I select another bookmark
group, hit CMD-B to go back to my web page, select "Show all bookmarks" (or
CMD-B) again, and I'm back at the "Bookmark Menu" group, though it preserve the
expanded state of sub-folders in the "Bookmark Menu" group.
Assignee

Comment 7

14 years ago
OK, I need to remmeber the selected container too.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Updated

14 years ago
Status: REOPENED → ASSIGNED
Summary: Show All Bookmarks should remember that last state of the bookmark tree → Show All Bookmarks should remember that last state of the bookmark tree, and selected container

Comment 8

14 years ago
*poke* Any progress? It seems like a pretty glaring error for a 1.0, though I
have no idea how easy it is to fix.
Assignee

Comment 9

14 years ago
Fixed on trunk.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
Assignee

Updated

14 years ago
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.