Status

()

--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: megadesigner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:nse])

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: firefox 1.0.3

Page file grows very fast on a very simple javascript -- in is not connected 
with javascript engine itself, -- it just forms the string in cause of which 
firefox grows very very fast in memory and fills all the pagefie, after all 
exits with mistake.

Reproducible: Always

Steps to Reproduce:
1. just wanna know, is it critical?
2.
3.

Actual Results:  
windows work very very slow

Expected Results:  
overflows

if you need the source i can send you ))))
(Reporter)

Comment 1

14 years ago
Also can generate huge amount of traffic. It contains src attribute of <image> 
for example that include about 50000 of "./" repeats. Normally, simple path of 
255 symbols ("/" repeats) is accepted in src by firefox, but if change "/" 
to "./" repeats firefox can (possible)  ask server infinitely for actually the 
same dir. So that. But it works, firefox crashes, loosing all tabs opened (why 
still not fixed?????) 
> if you need the source i can send you

Yes, please attach a testcase to the bug.
Whiteboard: [sg:needinfo]
(Reporter)

Comment 3

14 years ago
-- two files that crashes firefox

http://soulight.narod.ru/hack.htm
http://soulight.narod.ru/hack.txt

I don't crash, I get a javascript "out of memory" error. Memory usage does hit
the roof, but once the page is closed I get it back on the next GC.
Group: security
Whiteboard: [sg:needinfo] → [sg:nse]
(Reporter)

Comment 5

14 years ago
May there is too much of string addition's? If you delete some of them script 
should work without javascript error and url should be passed to to browser, 
after all browser hangs or crashes.
(Reporter)

Comment 6

14 years ago
fixed. i removed some of additions from js now it should work fine ). It may 
not crash firefox, because i don't have ability to install firefox :/

Comment 7

14 years ago
does not crash with FF 1.0.4 and Mozilla trunk, both Win2k, normal memory usage

Comment 8

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511
Firefox/1.0.4

Also unable to reproduce (Windows XP). Will mark as WORKSFORME unless someone
can provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.