Last Comment Bug 293850 - Requesting registration for l10n of firefox in Hindi language for India ( hi-IN )
: Requesting registration for l10n of firefox in Hindi language for India ( hi-...
Status: RESOLVED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Localization Registration Bugs
:
:
Mentors:
http://wiki.mozilla.org/L10n:Localiza...
: 306050 331731 (view as bug list)
Depends on: 300569
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-11 22:24 PDT by Akash
Modified: 2014-05-08 09:44 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Hindi XPI for Firefox upto 1.0.3 (310.43 KB, application/x-xpinstall)
2005-05-27 23:17 PDT, RKVS Raman
no flags Details
Attachment of Firefox Translation (297.85 KB, application/zip)
2005-12-18 02:24 PST, Rajesh Ranjan
no flags Details
Firefox 2.0 Hindi Translations Jar file (259.94 KB, application/java-archive)
2007-11-19 21:05 PST, RKVS Raman
no flags Details
Thunderbird 2.0 Hindi Translations Jar file (377.30 KB, patch)
2007-11-19 21:07 PST, RKVS Raman
no flags Details | Diff | Splinter Review
Sunbird 2.0 Hindi Translations Jar file (File 1) (148.62 KB, patch)
2007-11-19 21:08 PST, RKVS Raman
no flags Details | Diff | Splinter Review
Sunbird 2.0 Hindi Translations Jar file (File 2) (47.60 KB, patch)
2007-11-19 21:08 PST, RKVS Raman
no flags Details | Diff | Splinter Review

Description Akash 2005-05-11 22:24:17 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Requesting registration for l10n of firefox in Hindi and Tamil ( hi-IN, ta-IN )

Name: Matrubhasha and BharateeyaOO group
Contact Email: matrubhasha@ncb.ernet.in, akashmahajan@gmail.com
Website: http://www.ncb.ernet.in/matrubhasha
Language Code: hi, ta
Nation Code: IN
hi-IN, ta-IN

Reproducible: Always
Comment 1 Axel Hecht 2005-05-17 04:38:45 PDT
RKVS, have you seen this bug?

To those interested in a hindi localisation of Firefox, could you please contact 
mlp-staff with a status report?

Thanks.
Comment 2 Pavel Franc - Mozilla.cz 2005-05-19 09:45:09 PDT
And there is also a registration bug for Tamil localization (ta-IN) - bug 283960
with attached Tamil Language pack for Firefox 1.0.1. 

To those interested in a Tamil localisation of Firefox, I would suggest to join
the Thamizha group who makes also Mozilla Suite Tamil localization.
Comment 3 Akash 2005-05-19 21:25:21 PDT
(In reply to comment #1)
> RKVS, have you seen this bug?


RKVS Raman is the project leader of the team which has done the translations.
The idea is to have a regular process where builds for Firefox in Hindi are
available as soon as possible after a new version in en-US is released. 

> 
> To those interested in a hindi localisation of Firefox, could you please contact 
> mlp-staff with a status report?

Could you clarify this remark. A little background. 
This bug was filed only because we never got a response from
mlp-staff@mozilla.org for our emails. Filing a bug report was suggested by
Robert Kaiser. I am afraid we are running around in circles here. Unless you are
trying to tell us something different.

regards
Akash
Comment 4 RKVS Raman 2005-05-27 23:17:12 PDT
Created attachment 184744 [details]
Hindi XPI for Firefox upto 1.0.3

This is the xpi for hi-IN locale. Can be used as an addon also
Comment 5 Pavel Franc - Mozilla.cz 2005-05-28 04:31:26 PDT
> This is the xpi for hi-IN locale.

Ok, I put you under Hindi (hi-IN) localization on our wiki page -
http://wiki.mozilla.org/L10n:Localization_Teams

In order to commit Hindi localization of Firefox you need to apply for CVS
account - see bug 263726 as an example. You need also provide this localization
in form of CVS structure for review. 
Comment 6 Axel Hecht 2005-08-17 07:32:49 PDT
Comment on attachment 184744 [details]
Hindi XPI for Firefox upto 1.0.3

We still need a source tree of your localization.

Either for the 1.0.x Branch, or preferably, for the Mozilla1.8 branch, so that
we could release Firefox 1.5 off of that.
Comment 7 Axel Hecht 2005-08-27 07:15:15 PDT
*** Bug 306050 has been marked as a duplicate of this bug. ***
Comment 8 Axel Hecht 2005-08-28 06:54:40 PDT
CCing Gerv, he's Payal's mentor on the google soc program.
Comment 9 Gervase Markham [:gerv] 2005-10-25 04:18:29 PDT
We need to sort out which of RKVS Raman and Payal Chakravarty is going to actively maintain the Hindi localisation going forward.

Akash/RKVS Raman: do either of you wish to be the maintainer? If so, please supply an updated localisation in the form of a CVS tree, as requested in comment #5, within the next two weeks.

If not, Payal has indicated that she is willing to do it, and we will go forward based on her work.

Opera have been bragging that they are the only browser with both Hindi and Punjabi:
http://www.opera.com/pressreleases/en/2005/10/17/
It would be nice to get a Hindi localisation for 1.5, even if we don't now have time to do a simultaneous release.

Gerv
Comment 10 RKVS Raman 2005-11-15 03:50:56 PST
Hello,

Let me introduce Rajesh Ranjan ( rajeshkajha@yahoo.com ). He is already coordinator for Thuderbird (mail).He has good coordination with my team also, and I have already given him the permission to use Firefox common file earlier. Since Rajesh has shown interest in Firefox maintanenceand I know him as a responsible person I allow him to work as a Maintainer/Coordinator of Firefox (Browser+Toolkit) Hindi .

Rajesh will update the Firefox CVS in another couple of days

Hope this settles all issues.

-Raman






(In reply to comment #9)
> We need to sort out which of RKVS Raman and Payal Chakravarty is going to
> actively maintain the Hindi localisation going forward.
> 
> Akash/RKVS Raman: do either of you wish to be the maintainer? If so, please
> supply an updated localisation in the form of a CVS tree, as requested in
> comment #5, within the next two weeks.
> 
> If not, Payal has indicated that she is willing to do it, and we will go
> forward based on her work.
> 
> Opera have been bragging that they are the only browser with both Hindi and
> Punjabi:
> http://www.opera.com/pressreleases/en/2005/10/17/
> It would be nice to get a Hindi localisation for 1.5, even if we don't now have
> time to do a simultaneous release.
> 
> Gerv
> 
Comment 11 Gervase Markham [:gerv] 2005-12-08 07:56:10 PST
Raman: it's all very well you nominating someone else to do the work, but they need to come up with the goods. :-) 

Please attach an updated localisation for Firefox 1.5 to this bug in the form of a CVS tree, as requested in comment #5, within the next week or we will ask Payal to take over maintenance of the Hindi localisation. As I'm sure you can imagine, we need to make progress here, and there are other people who are eager to do the work.

Gerv
Comment 12 Rajesh Ranjan 2005-12-08 20:25:01 PST
Hi
I will sure submit the file by the end of the next week. Currently I am going through the QA part of translation. I already submitted the Thuderbird translation long before --

https://bugzilla.mozilla.org/show_bug.cgi?id=300569

Regards,
Rajesh
Comment 13 Rajesh Ranjan 2005-12-18 02:24:19 PST
Created attachment 206239 [details]
Attachment of Firefox Translation

Hi
I am submitting the Firefox translation. Thunderbird translation is 
already submitted earlier with Following Bug

https://bugzilla.mozilla.org/show_bug.cgi?id=300569

Regards,
Rajesh Ranjan
Comment 14 Axel Hecht [:Pike] 2005-12-18 23:47:49 PST
I'll try to look at this over the holidays.

Thanks
Comment 15 Axel Hecht [:Pike] 2005-12-18 23:56:59 PST
Comment on attachment 206239 [details]
Attachment of Firefox Translation

putting this on my radar
Comment 16 Axel Hecht [:Pike] 2006-01-03 03:52:12 PST
Comment on attachment 206239 [details]
Attachment of Firefox Translation

This localization is not done yet, but enough to vouch in the other bug, unsetting the flag.
Comment 17 Guntupalli Karunakar 2006-03-08 03:42:28 PST
what is the status of this currently. i dont see firefox hindi langpacks coming regularly.

i would like to take maintaining langpacks for releases.
presently i coordinate kde+gnome hindi.
Comment 18 Rajesh Ranjan 2006-03-08 04:03:36 PST
https://bugzilla.mozilla.org/show_bug.cgi?id=300569

It is fixed now. And I already pushed in all the files in the CVS. 
I am working on... 
Thanks that you showed interest for firefox. Hope for the 'baby' soon. 
I will really appreciate review from you and your team.

Comment 19 Guntupalli Karunakar 2006-03-08 04:22:51 PST
which version of firefox is this going to be?
Comment 20 Axel Hecht [:Pike] 2006-03-08 04:30:39 PST
OK, I hope I did get everything right, and entered Rajesh as owner for fx and tb.
Please check the wiki entry above.

As for versions, we're working towards some 1.5.0.x right now, we'll see how
quick we get there.
Comment 21 Guntupalli Karunakar 2006-05-19 04:27:13 PDT
is someone making a langpack for hindi, for the latest 1.5.0.3 , I see gu-IN & pa-IN available.
I could help maintain hi-IN langpack, if i can get steps to create one (1.5 version)
Comment 22 Axel Hecht [:Pike] 2007-01-09 02:40:12 PST
*** Bug 331731 has been marked as a duplicate of this bug. ***
Comment 23 RKVS Raman 2007-11-19 05:47:43 PST
Hello,


Hindi translations for Firefox 2.0 , Thunderbird 2.0 and Sunbird are nearly
over. 

Rajesh please help me in checking them in..

Thanks.


-Raman
Comment 24 Rajesh Ranjan 2007-11-19 20:28:36 PST
Hi,

Firefox and thunderbird is almost ready to release.

Can you please attach the files. So that I can check in for Sunbird.

Thanks a lot for your team's contributions.

Regards,

Rajesh
Comment 25 RKVS Raman 2007-11-19 21:05:35 PST
Created attachment 289443 [details]
Firefox 2.0 Hindi Translations Jar file 


Firefox 2.0 hindi localized files
Comment 26 RKVS Raman 2007-11-19 21:07:03 PST
Created attachment 289444 [details] [diff] [review]
Thunderbird 2.0 Hindi Translations Jar file 

Thunderbird 2.0 Hindi Translations Jar file
Comment 27 RKVS Raman 2007-11-19 21:08:18 PST
Created attachment 289446 [details] [diff] [review]
Sunbird 2.0 Hindi Translations Jar file  (File 1)

Sunbird 2.0 Hindi Translations Jar file  (File 1)
Comment 28 RKVS Raman 2007-11-19 21:08:57 PST
Created attachment 289447 [details] [diff] [review]
Sunbird 2.0 Hindi Translations Jar file  (File 2)

Sunbird 2.0 Hindi Translations Jar file  (File 2)
Comment 29 RKVS Raman 2007-11-19 21:10:26 PST
All the files have been uploaded

Please check them in.



-Raman
Comment 30 Axel Hecht [:Pike] 2007-11-20 01:11:06 PST
Raman, please invest some time to learn more about contributing to mozilla. That's documented in http://wiki.mozilla.org/L10n:Localization_Process, for the l10n-specific part. http://developer.mozilla.org/en/docs/Developing_Mozilla has the overall picture.

The short story is, "we don't take jars", and "we don't just check stuff in".

I'll leave it up to Rajesh what he wants to do with these attachments, but the really constructive way to come up with contributions is to create patches for particular changes, to create bugs for those in the Mozilla Localizations, Hindi component and ask for review and then check-in.
http://developer.mozilla.org/en/docs/Patching_a_Localization has some technical information on that.
Note that creating patches does not require CVS write access, too. New files are a tad different, the non-firefox stuff for TB and SB might be well placed in a tar file. Of course, those should be in the directory structure of the source, and not in all-together jar files. And in new bugs, too, this one is done.
Comment 31 RKVS Raman 2007-11-20 01:12:52 PST
ooops sorry.

Will do as you said. 

Thanks.

-Raman
Comment 32 Axel Hecht [:Pike] 2007-11-20 01:14:31 PST
Thanks.
Comment 33 Jason Smith [:jsmith] 2014-03-22 23:57:26 PDT
Please don't nominate bugs you don't understand.

Note You need to log in before you can comment on or make changes to this bug.