incorrect time saved in published .ics file

RESOLVED DUPLICATE of bug 199422

Status

RESOLVED DUPLICATE of bug 199422
14 years ago
12 years ago

People

(Reporter: dschout, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20050203 Mozilla Sunbird/0.2

I'm linked to multiple Calendars of my colleagues.

When copying one of their events to my onw calendar, the times are not properly
taken over.

1. a random start and end time seems to be choosen
2. the start and end time are now stored in "universal" time rather than my local

Reproducible: Always

Steps to Reproduce:
1. link to a remote published calendar
2. create your own published calendar
3. now copy an event from the linked calendar to your own published calendar

Actual Results:  
Local in Sunbird the start and end times are just messed up
After changing the times to what they should be, it all seems correct in the
local view
When viewing the combined calendars in PHP iCalendar 1.1, you see that universal
time is being used for the newly published calendar, so the copied events have
different start and end times

Expected Results:  
The copy action should take the original start and end time
And it should use the same time settings as when creating a new event
New events do have their time set correctly and are properly shown even when
using PHP iCalendar 1.1

Comment 1

14 years ago
(In reply to comment #0)
> 1. a random start and end time seems to be choosen
> 2. the start and end time are now stored in "universal" time rather than my >local

At first glance, I'd say that this is related to bug 230371.  Are you sure that
the times are completely random?  This would be something new if they were. 
Instead, can you check and see if they are all off the correct time by the same
amount (probably your time-zone offest)?

Also, do you have 'Store dates in Universal Time' checked in the preferences
window?  Does checking/unchecking help the situation?
(Reporter)

Comment 2

14 years ago
In regards to the times that seem to be choosen when copying an event:

I tried enabling the use 'Store dates in Universal Time', but this would cause
all my manually entered events to also show up on the wrong times in iCallendar.
Probabbly because iCallendar cannot take into account my tome-zone setting as
these are not stored in the Sunbird created calendars.

I copied 2 events that were set at the same time and at the same location (15:00
GMT+1 Copenhagen,DK) One came from my local calendar, and one from a published
one from a colleague. My local settings are Amsterdam, NL.
I copied 2 more events that were set at the same time and at the same location
(10:30 GMT+1 Copenhagen,DK) One came from my local calendar, and one from a
published one from a colleague.

All the new events look ok in Sunbird.
But the iCalendar time shows them all set to 08:00 AM. (although they have 2
different originating times)

I did the same for 2 events in Stockholm, DK.
It looks ok in Sunbird, but the iCalendar time shows them at 08:30

One thing I noticed in the sunbird created .ics files is the following:

There are no locale/region setting used what so ever, not in the header and not
in the events:

event:

DTSTART
 :20050517T090000

While in the .ics file from the calendar that I link to they are used:

header:

X-WR-TIMEZONE
 :Europe/Amsterdam
CALSCALE
 :GREGORIAN

event:

DTSTART
 ;TZID=Europe/Amsterdam
 :20050503T113000


Would it not be fairly easy to add these settings?

And for the moment when you publish a calendar that has no events, you cannot
link to it anymore to add events.
Including the locale and other settings in a header even when the calendar is
empty could solve this issue as well.

Comment 3

14 years ago
(In reply to comment #2)
> There are no locale/region setting used what so ever, not in the header and not
> in the events:
> 
> event:
> 
> DTSTART
>  :20050517T090000
> 
> While in the .ics file from the calendar that I link to they are used:
> 
> header:
> 
> X-WR-TIMEZONE
>  :Europe/Amsterdam
> CALSCALE
>  :GREGORIAN
> 
> event:
> 
> DTSTART
>  ;TZID=Europe/Amsterdam
>  :20050503T113000

The TZID field is the proper way to identify the timezone the event is scheduled
in.  I don't think the X-WR-TIMEZONE option is part of RFC2445.  Unfortunately,
the 'This doesn't do anything yet' description in the timezone option is
probably as good of an explanation as you're going to get as to why the locale
information isn't stored.  However, work is being done currently to improve
Sunbird's timezone support, hopefully in 0.3.

> And for the moment when you publish a calendar that has no events, you cannot
> link to it anymore to add events.
> Including the locale and other settings in a header even when the calendar is
> empty could solve this issue as well.
>

I think you're describing what is discussed in bug 218983 comment 3.
 

Comment 4

14 years ago
From email:"I was searching through the bug list to find one related or similar
to the time copy issue I noticed... and I think it is similar to 199422"

Diederik,
Given our email discussion, do you have any objection to resolving this bug as a
duplicate of bug 199422?
(Reporter)

Comment 5

14 years ago
No, I agree to see this as a duplicate of 199422.

Although slightly different in nature, looking at the code rewrite/restructuring
required etc, this will have to be tested after the changes for 199422 have been
made.

*** This bug has been marked as a duplicate of 199422 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.