Alt+nnnn characters cannot be entered in form fields correctly

RESOLVED DUPLICATE of bug 292438

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 292438
13 years ago
10 years ago

People

(Reporter: Neil P. Pena, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050509 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050509 Firefox/1.0+

When trying to enter an Alt+nnnn (extended) character in a form field, if the
page has links with numbered access keys (Alt+1 for example), entering an
extended character including that number (Alt+0174 for example) causes the
numbered link to activate when the number is pressed, making it impossible to
input the extended character.

Reproducible: Always

Steps to Reproduce:
1. Go to any web page that has form fields and also numbered access keys.  I'll
use http://forums.beyondunreal.com as an example.
2. In either the User Name or Password fields in the top right, try entering the
extended character Alt+0202

Actual Results:  
Because the part of the extended character included the number 2, and the
"Today's Posts" link in the example page has the access key "2", the "Today's
Posts" link gets activated.

Expected Results:  
The extended character È should have been input into the form field, and no
links should be activated.

This happens in the 20050509 nightly build for Windows (and at least a couple
other builds that I have tried preceding that date), but I don't remember this
being a problem in earlier versions of Firefox (including 1.0/1.0.1/1.0.2/1.0.3).
(Reporter)

Comment 1

13 years ago
Oh, another thing I forgot to mention earlier.  The behaviour I described above
happens when Num Lock is turned on.  If Num Lock is turned off, then the
behaviour does not occur.  However, trying to enter a character such as Alt+0174
with the Num Lock off will fail, because in that case when the 7 is encountered,
Firefox sees that as Alt+Home, and sends the browser to the home page.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 292438 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 3

13 years ago
> Firefox sees that as Alt+Home, and sends the browser to the home page.
Aditional: Alt+4 is "Back" and Alt+6 is "Forward"
So turning Num Lock off is no good workaround.
You need to log in before you can comment on or make changes to this bug.