Non-empty bookmark folders show (Empty) on first view

RESOLVED EXPIRED

Status

()

--
trivial
RESOLVED EXPIRED
14 years ago
13 years ago

People

(Reporter: zidane2k1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050511 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050511 Firefox/1.0+

The first time that a non-empty bookmark folder is opened (either from the
Bookmarks menu or the Bookmarks Toolbar), a grayed-out "(Empty)" item appears in
the menu above the bookmarks in the folder.  The next time the folder is opened,
the "(Empty)" item is no longer there, and it remains gone for the remainder of
the session, until Firefox is started again.

Reproducible: Always

Steps to Reproduce:
1. Start a fresh instance of Firefox.
2. On the Bookmarks menu or Bookmarks Toolbar, open any folder that has
bookmarks in it.
Actual Results:  
You see a greyed-out "(Empty)" entry above the bookmarks in that folder the
first time you look in the folder.

Expected Results:  
"(Empty)" should not have been shown at all, since there are bookmarks in the
folder.
(Reporter)

Comment 1

14 years ago
Created attachment 183425 [details]
Menu appearance on first view
(Reporter)

Comment 2

14 years ago
Created attachment 183426 [details]
Menu appearance on second and further views
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED

Comment 5

13 years ago
This has popped up for me in Firefox 1.5.0.1 and Firefox 1.5.0.2 in Ubuntu Dapper (it didn't happen in Breezy).

It occurs in KDE, Gnome, and XFCE; regardless of which user I use or if I use a fresh profile, regardless of whether I use Mozilla's Firefox or Ubuntu's Firefox.
You need to log in before you can comment on or make changes to this bug.