Crash when posting comments on Livejournal

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: boogs, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511

Hi,

In recent times, I've found that when I post a comment to an entry in someone's
journal on Livejournal (http://www.livejournal.com), Mozilla occasionally
crashes when the form is submitted. This crash can either be a "regular" crash
(subsequently caught by the Talkback utility), or a lockup where Mozilla
consumes 99% CPU time but does not actually react to user interaction in any
way. FWIW, the actual form content does get submitted before the crash (i.e.,
the posted comment appears after restarting Mozilla).

This behaviour is not directly reproducible, but can be observed fairly
regularly nonetheless; I have not been able to link it to specific conditions yet.

The problem started at around the time when I downloaded Mozilla 1.7.7 (FWIW,
it's still there in 1.7.8, too); I'm not sure whether the problem may have been
caused by code changes on livejournal.com, but in any case, Mozilla shouldn't
crash even on bad code. ;) 



Reproducible: Sometimes

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
After having been bitten by this many more times, I think it's reasonably safe
to say that this occurs specifically when I change tabs (using Ctrl-Tab or
Ctrl-Shift-Tab) while the form content is being submitted.

That being said, does anyone actually care about this? I'd expect that the bug
would at least be assigned to the proper component owner by now (I'm not sure
which one that is, which is why I filed it as a general bug). I'm not trying to
assign blame etc., but it'd be nice if I actually knew whether I'm wasting my
time filing bugs etc. or not.
(Reporter)

Comment 2

13 years ago
Confirmed to still exist in 1.7.11 (Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.7.11) Gecko/20050728).

Comment 3

13 years ago
I experiance this as well, not only on livejournal but in any generic POST
submission

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050910 Firefox/1.4

Comment 4

13 years ago
I have a reproducible problem - but I'm not sure if it is related to this bug or something else. Plus it is obviously related to the display driver I'm using. However, I've only ever seen this through Mozilla.
It came up when I tried to validate Django's CSS web page.

When I enter the attached URL into an address bar or some form bars, my PC freezes for a few moments, then the display driver "resets"? I get a message saying that the ialmrnt5 display driver has stopped working and that I should save my work. I can actually see the results of my request, and navigate the browser, but I'm guessing this behaviour changes depending on exactly the hardware setup people have.

I've also seen several posts that seem related and I'm hoping this might clarify  why there is a problem. It seems to happen on HTML GET and POST actions. I think the URL contains some character string that sends Mozilla for a loop.

Found on WinXP SP 2, using serveral Mozilla builds including:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060109 SeaMonkey/1.5a

Comment 5

13 years ago
Created attachment 208029 [details]
Trying attachment again

I have a reproducible problem - but I'm not sure if it is related to this bug or something else. Plus it is obviously related to the display driver I'm using. However, I've only ever seen this through Mozilla.
It came up when I tried to validate Django's CSS web page.

When I enter the attached URL into an address bar or some form bars, my PC freezes for a few moments, then the display driver "resets"? I get a message saying that the ialmrnt5 display driver has stopped working and that I should save my work. I can actually see the results of my request, and navigate the browser, but I'm guessing this behaviour changes depending on exactly the hardware setup people have.

I've also seen several posts that seem related and I'm hoping this might clarify  why there is a problem. It seems to happen on HTML GET and POST actions. I think the URL contains some character string that sends Mozilla for a loop.

Found on WinXP SP 2, using serveral Mozilla builds including:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060109 SeaMonkey/1.5a

Comment 6

13 years ago
please submit talkback incidents when you crash and report the talkback IDs here

also try a more recent build:
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/
Keywords: crash

Comment 7

12 years ago
My apologies about the comment, I should have been clearer. (Also I lost one attachment attempt somehow which might also seem confusing.)
Every other aspect of the bug - 99% CPU activity, long delay time, form actually submitted - occurred in my case, the only difference was that instead of Mozilla crashing I had my display driver "stop working". So I didn't see any TalkBack - I can try to catch some more info while this occurs but if it takes more than just trying the URL I will need some guidance!

As I mentioned this occured on the SeaMonkey nightly build 20060109, which I grabbed specifically to reproduce this bug.

I guess the iron test is to try the URL I attached on some other Windows PC and see if the problem can be reproduced there. If this is somehow just related to my display chip, then (even if it is triggered by Mozilla) I don't think it is terribly important.
Works for me on 1.1.9 and trunk.

Could you try a recent version of SeaMonkey or nightly (http://www.seamonkey-project.org/releases/) please?

Comment 9

10 years ago
WFM too with SeaMonkey 1.1.9 Release and current Trunk-Nightly-builds on Windows XP and Linux, no crash.

So I close this now as resolved=worksforme.

Reporter, Rob, if you still have this issue using current Builds, feel free to reopen and give actual information. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.