Print to pdf from Firefox print preview: css-styled tables lack borders

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Moon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

When I do a print preview of that page and select to show background and images
the table looks just fine. After printing to pdf the resulting pdf lacks table
borders.

Reproducible: Always

Steps to Reproduce:
1.View said page in print preview, enabling background and images
2.Print the file to pdf (you need Adobe Acrobat - NOT reader - installed)
3.View the resulting pdf in Acrobat Reader

Actual Results:  
The layout comes close to the original HTML but the tables lack borders, check
out this screenshot: http://img249.echo.cx/img249/7484/pdfnoborder27rq.png


Expected Results:  
The pdf should look as the HTML page does in Firefox.

The regulars of comp.text.pdf assume it's a Firefox or HTML/CSS issue rather
than a problem of Adobe Acrobat. I've used Adobe Acrobat 6 on Windows XP and
viewed the pdf in Acrobat Reader 7.

Comment 1

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.7)
Gecko/20050414 Firefox/1.0.3
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.7)
Gecko/20050414 Firefox/1.0.3
> 
> When I do a print preview of that page and select to show background and images
> the table looks just fine. After printing to pdf the resulting pdf lacks table
> borders.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.View said page in print preview, enabling background and images
> 2.Print the file to pdf (you need Adobe Acrobat - NOT reader - installed)
> 3.View the resulting pdf in Acrobat Reader
> 
> Actual Results:  
> The layout comes close to the original HTML but the tables lack borders, check
> out this screenshot: http://img249.echo.cx/img249/7484/pdfnoborder27rq.png
> 
> 
> Expected Results:  
> The pdf should look as the HTML page does in Firefox.
> 
> The regulars of comp.text.pdf assume it's a Firefox or HTML/CSS issue rather
> than a problem of Adobe Acrobat. I've used Adobe Acrobat 6 on Windows XP and
> viewed the pdf in Acrobat Reader 7.

I have a similar problem with CSS borders. I also lack borders when printing to
a PDF or straight to printer. Internet Explorer prints the borders fine to both
PDF or the printer.

Comment 2

13 years ago
(In reply to comment #1)

I think I've been able to narrow down the problem: Using CSS rule "td {border:
thin black solid}" works for preview, but is not printed. Changing the rule to
"td {border: 1px black solid}" makes this work. "thin" seems to be the problem.

Both work fine in IE, for preview and print.

Updated

13 years ago
Depends on: 307367

Comment 3

13 years ago
I have added comments and attachments to bug N. 314839 on printing problems ("Printing/Preview of letter format page on A4 looses right margin") but now I think that I should have added my comments to this bug report.
I apologize

danyliscia@libero.it
Using Firefox 2.0.0.3 on Windows XP and Mac OS X, the print preview doesn't show any colors in the table, which is correct. What shows in print preview is exactly what prints.

I'm closing this bug as WFM. If you're able to reproduce and can provide a specific testcase to attach to this bug which exhibits the problem in Firefox 2.0.0.3 or later, please do so and reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.