[Mac] Auto-complete box not dismissed by click on drop-down element

RESOLVED DUPLICATE of bug 269034

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 269034
13 years ago
11 years ago

People

(Reporter: Joachim Noreiko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Clicking away from a form text element should dismiss the auto-complete box.

However, if the user clicks on a drop-down list form element, it has no effect.

Reproducible: Always

Steps to Reproduce:
1. Use a form so it has auto-complete data (http://www.traintimes.org.uk/ is a
good example)
2. Begin typing in the text field
3. Auto-complete box pops up
4. At any point (whether you've typed all the text or not) click on a drop-down
element

Actual Results:  
The auto-complete box vanishes then reappears immediately. Focus is not shifted
to the element that was clicked.

Expected Results:  
Shifted focus and dismissed the auto-complete box.

Comment 1

13 years ago
Also seeing this on Linux. Particularly annoying if you middle-click to paste
text into a text box, which triggers autocomplete. IMDB's quick search
demonstrates this repeatably.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416
Fedora/1.0.3-1.3.1 Firefox/1.0.3

Comment 2

13 years ago
This bug might require different fixes on Mac and on Linux, so comment 1 is bug
188126 or bug 262123 or a separate bug.
Status: UNCONFIRMED → NEW
Component: Form Manager → Location Bar and Autocomplete
Ever confirmed: true
QA Contact: form.manager → location.bar
Summary: Auto-complete box not dismissed by click on drop-down element → [Mac] Auto-complete box not dismissed by click on drop-down element

Comment 3

13 years ago
*** Bug 301245 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
Confirmed on trunk with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.8b4) Gecko/20050806 Firefox/1.0+

Comment 5

12 years ago
Using Firefox 1.5 RC1 OS X (10.2.8), when autocomplete is used and a list of possible entries results, the whole application freezes. Nothing unfreezes it except for force quit. I have seen this happen in 1.5 alpha and 1.5 beta. It's been going on for over a month, in other words. This does not happen in 1.0.7. I can only conclude that the only stable version of Firefox for Mac OS X is 1.0.7.

Comment 6

12 years ago
Created attachment 224150 [details]
uto complete does not show on taskbar when on a site that uses saved passwords.

Auto complete does not show on taskbar when a site requests info.

Comment 7

12 years ago
Comment on attachment 224150 [details]
uto complete does not show on taskbar when on a site that uses saved passwords.

"DOWNLOAD ATTACHMENT LINK" GIVES A MESSAGE THAT SAYS "WINDOWS CANNOT OPEN FILE"

Comment 8

12 years ago
Comment on attachment 224150 [details]
uto complete does not show on taskbar when on a site that uses saved passwords.

Cannot download attachment. Windows says "cannot open file."
Attachment #224150 - Attachment is patch: true
Attachment #224150 - Attachment mime type: application/octet-stream → text/plain

Comment 9

12 years ago
Comment on attachment 224150 [details]
uto complete does not show on taskbar when on a site that uses saved passwords.

"DOWNLOAD ATTACHMENT LINK" GIVES A MESSAGE THAT SAYS "WINDOWS CANNOT OPEN FILE"
Attachment #224150 - Attachment is patch: false
Attachment #224150 - Attachment mime type: text/plain → application/octet-stream

Comment 10

12 years ago
*** Bug 344811 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 269034
You need to log in before you can comment on or make changes to this bug.