Last Comment Bug 29407 - [DOGFOOD] Cannot open additional browsing windows, Javascript error in the chrome.
: [DOGFOOD] Cannot open additional browsing windows, Javascript error in the ch...
Status: VERIFIED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Linux
: P3 blocker (vote)
: M14
Assigned To: Christine Begle
: Asa Dotzler [:asa]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-26 21:44 PST by Jason Eager
Modified: 2004-11-22 17:25 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Jason Eager 2000-02-26 21:44:07 PST
This is Linux nightly build 2000022609

Attempting to open additional browsing windows through any method
(including the New option under the file menu, or clicking on the
browser icon at the bottom of the window, does not create a new
browser window, instead it causes this javascript error:

In OpenBrowserWindw()...
JavaScript Error: TypeError: handler has no properties
URL: chrome://global/content/tasksOverlay.js
LineNo: 92

I looked at the code, and changed it so it did a getService call in one line.
That didn't work either...I got THIS error:

In OpenBrowserWindw()...
JavaScript Error: TypeError:
Components.classes['component://netscape/appshell/component/browser/cmdhandler']
has no properties
URL: chrome://global/content/tasksOverlay.js
LineNo: 91

So then I had a long chat with people in #mozilla:

<jband>	Jason: that progid is probably just not registered with the component
manager
<jband>	lxr search for cmdhandler finds it in only navigator.js and tasksOverlays.js
<jband>	but no code that is claiming to implement that component that I can see
<jband>	So what *is* cmdhandler?

<jband>	but the problem is that you don't have a handle to a componet instance
<JasonCEager>	and why don't I have a handle to a component interface?
<jband>	you have a progid that the component manager does not know about
<jband>	no on registered that progid

<jband>	Jason: I have an old tree. cmdhandler used to be in nsIBrowserInstance.idl
<jband>	It is not there now. try
component://netscape/commandlinehander/general-startup-browser it might be the
same thing
bruce>	that's due to a change yesterday by sspitzer.
<jband>	Jason: the -r 1.8 version of nsIBrowserInstance.idl changed this name.
bug sspitzer

So I made my final attempt to fix the chrome, and now I get
this error:

In OpenBrowserWindw()...
JavaScript Error: TypeError:
Components.classes['component://netscape/commandlinehandler/general-startup-browser']
has no properties
URL: chrome://global/content/tasksOverlay.js
LineNo: 91

So someone has changed the name of a component but hasn't
changed the name of the component in the chrome, and I have
no idea what component needs to be called.

So I'm going to have to drop back to 2000022209 until this
gets fixed or someone tells me what the correct component name is.

*sigh* I think this should be part of the smoke test for the build,
don't you think? Lots and lots of people depend on multiple browsing
windows.

Making as a blocker for M 14..this SHOULD be an easy fix.
Comment 1 Jason Eager 2000-02-26 21:46:09 PST
I *WANT* to assign this bug to sspitzer, but bugzilla doesn't seem to know
him/her at all. :-(

Also marked as blocker on M14 (which I thought i did in the first place).

Comment 2 Jesse Ruderman 2000-02-26 21:57:01 PST
Shouldn't M14 be code-frozen now? 
http://mozilla.org/projects/seamonkey/milestones/progress-2-beta.html says it's 
due out in two days.
Comment 3 Richard Zach 2000-02-26 22:08:22 PST
CC: seth
Comment 4 Jason Eager 2000-02-26 22:15:01 PST
Blizzard's check in does not fix this problem. I looked at it in bonzi and
manually applied it.

1) The javascript error still pops up in a global chrome file, not that
navigator.js file that he patched. That may allow javascript to pop up a new
version of a navigator, but it does not get called when a user attempts to
manually open another navigator window.

2) I think the fix has a typo in it, unless the component is really called
commandlineHANDER and not commandlineHANDLER.

Is there a way to get a list of components? If there was, I could probably
figure this out on my own.


Comment 5 Dawn Endico 2000-02-26 22:55:42 PST
This works in my build dated Feb 26 12:03, so whatever broke it was probably
checked in some time after 11:00.
Comment 6 Christopher Blizzard (:blizzard) 2000-02-27 11:53:40 PST
Actually, my checkin did fix the problem.  The really funny thing is that it's
misspelled in the .idl file, too.  I just cut-n-pasted the component:// url.  I
didn't notice.

Seth, can I fix this?  It's in nsIBrowserInstance.idl and in two .js files. 
Look at the NS_BROWSERSTARTUPHANDLER_PROGID define.
Comment 7 (not reading, please use seth@sspitzer.org instead) 2000-02-27 12:11:34 PST
I misspelled it all over the place.

http://lxr.mozilla.org/seamonkey/search?string=hander

yes, please fix them all.
Comment 8 Christopher Blizzard (:blizzard) 2000-02-27 12:51:37 PST
I fixed all the misspellings.
Comment 9 (not reading, please use seth@sspitzer.org instead) 2000-02-27 13:16:00 PST
clearing status whiteboard, blizzard has fixed it.

marking verified

Note You need to log in before you can comment on or make changes to this bug.