.mozilla/[product] directory choice corruption on Unix with debug build

RESOLVED WONTFIX

Status

()

Toolkit
Startup and Profile System
--
blocker
RESOLVED WONTFIX
13 years ago
6 years ago

People

(Reporter: green, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.8) Gecko/20050513 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.8) Gecko/20050513 Firefox/1.0.4

When I start Firefox built for debugging, I get the "no profiles for firefox"
exist rigamarole each time.  Trash directories named .mozilla/[trash] are
created each time.

Reproducible: Always

Steps to Reproduce:
1. make config in ports/www/firefox and enable debugging
2. build, install, run



It's a bug in the Unix XRE regarding C++ stack usage.
(Reporter)

Comment 1

13 years ago
Created attachment 183542 [details] [diff] [review]
patch to fix the stack-use bugs

This fixes it for me.
Assignee: dougt → nobody
Status: UNCONFIRMED → NEW
Component: Embedding: GRE Core → XRE Startup
Ever confirmed: true
Product: Core → Toolkit
QA Contact: nobody
Version: Trunk → unspecified
green@FreeBSD.org: You need to ask for review for this bug to progress. Seems like it still applies.

Updated

10 years ago
Component: XRE Startup → Startup and Profile System
QA Contact: nobody → startup

Comment 3

7 years ago
Is this still reproducible?
Whiteboard: closeme WONT 2012-04-01

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Whiteboard: closeme WONT 2012-04-01
You need to log in before you can comment on or make changes to this bug.