Drop on page targets text input even when not over it

RESOLVED DUPLICATE of bug 185943

Status

Camino Graveyard
Drag & Drop
RESOLVED DUPLICATE of bug 185943
13 years ago
13 years ago

People

(Reporter: Simon Fraser, Assigned: Simon Fraser)

Tracking

({regression})

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
If you drag and drop text onto a web page which has a text input or textarea,
the caret will flicker in the first text input, and when you drop the text (or
url) will be inserted into that text input, even if the drop location is not
over the input.

This is bad, because it prevents you from loading a new page by dragging in a
link if there are form controls on a page.
(Assignee)

Comment 1

13 years ago
Created attachment 183564 [details]
Testcase
(Assignee)

Comment 2

13 years ago
I tested Firefox, and the problem does not occur there.
(Assignee)

Comment 3

13 years ago
This goes back at least to Camino 0.8.3.
There are a couple variants of this bug out there: bug 168378, bug 185943, bug
225862.  They all seem interrelated to me, but IANA dev :-)

(Assignee)

Comment 5

13 years ago
Ah, thanks. This is a dup of 185943.

*** This bug has been marked as a duplicate of 185943 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.