Closed Bug 294127 Opened 17 years ago Closed 17 years ago

When Camino is launched with a document, init order is incorrect

Categories

(Camino Graveyard :: General, defect, P2)

PowerPC
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED
Camino0.9

People

(Reporter: sfraser_bugs, Assigned: sfraser_bugs)

References

Details

Attachments

(1 file)

If you launch camino by dragging a file onto its icon, then you'll see some
console spewage in debug builds which indicates that we're trying to load stuff
before we've fully initted gecko:

###!!! ASSERTION: EnableGlobalHistory() failed: 'NS_SUCCEEDED(rv)', file
../../../../../mozilla/embedding/browser/webBrowser/nsWebBrowser.cpp, line 1208

WARNING: NS_ENSURE_TRUE(mRequest) failed, file
../../../../../../mozilla/netwerk/protocol/file/src/nsFileChannel.cpp, line 172

WARNING: NS_ENSURE_TRUE(mRequest) failed, file
../../../../../../mozilla/netwerk/protocol/file/src/nsFileChannel.cpp, line 172

WARNING: NS_ENSURE_TRUE(mRequest) failed, file
../../../../../../mozilla/netwerk/protocol/file/src/nsFileChannel.cpp, line 172

What's happening is that we handle the open document stuff before
-appDidFinishLaunching is called, so we haven't yet registered the app
components and done other setup.

The impact of this is that history is broken for that first browser view.
*** Bug 300616 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → Camino0.9
Attached patch PatchSplinter Review
This patch makes sure that we init gecko before doing stuff like handling
GetURL	or application:open: events on launch, since these are called before
-applicationDidFinishLaunching
Fixed.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1005391
You need to log in before you can comment on or make changes to this bug.