Closed Bug 294150 Opened 16 years ago Closed 16 years ago

50% Ts regression since landing of bug 293461

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED FIXED
Firefox1.5

People

(Reporter: stevee, Assigned: benjamin)

References

Details

(Keywords: regression)

Attachments

(1 file)

Flags: blocking-aviary1.1?
Ts went up by more like 60-70% on beast (Win) and imola (Mac).

Benjamin, can you back this out or fix ASAP?  I'll back this out tonight if no
action has been taken, since we're possibly spinning 1.1a1 Monday.
Flags: blocking1.8b2?
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1+
Hold off and talk to me this (Monday) morning... I'm debugging this now.
Assignee: nobody → benjamin
Depends on: 293548
This needs love for 1.1a, either the fix in bug 293548 or a backout of bug
293461... but a backout would be painful because other stuff has landed on top
of it.
Flags: blocking1.8b2? → blocking1.8b2+
Time is very short for 1.8b2/1.1a. If we're not gonna have a fairly safe fix
today, then let's back this out.
Asa: I'm planning on landing the patch for bug 293548, which will fix this bug.
My patch for bug 293548 is in, so I think we can mark this bug fixed.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
reopening... beast Ts did not come down after the patch landed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ben mentioned that you should verify that the EM cleans up its datasource when
the "extensions" folder happens to have been deleted.  For example, just go and
manually delete that folder, and then verify that EM recovers from that
situation.  I believe it should since we scan install locations at startup to
determine the actual items and then compare that against the known items to
determine what needs to be installed, removed, or updated.
Attachment #183830 - Flags: review?(darin) → review+
Comment on attachment 183830 [details] [diff] [review]
Remove silly "isFunctioning" test that always fails on new -createProfile builds

Low-risk, high-reward.
Attachment #183830 - Flags: approval-aviary1.1a1?
Comment on attachment 183830 [details] [diff] [review]
Remove silly "isFunctioning" test that always fails on new -createProfile builds

a=shaver.
Attachment #183830 - Flags: approval-aviary1.1a1? → approval-aviary1.1a1+
Fixed on trunk for 1.1a1.
Severity: normal → major
Status: REOPENED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox1.1
*** Bug 294740 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.