--[anything not null]> misinterpreted as a comment end tag for most DOCTYPEs

VERIFIED DUPLICATE of bug 229974

Status

()

Firefox
General
--
major
VERIFIED DUPLICATE of bug 229974
13 years ago
13 years ago

People

(Reporter: unadyyplzs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Firefox misinterprets --[anything not null]> as a comment end tag for all
DOCTYPEs (see http://htmlhelp.com/tools/validator/doctype.html) except:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">

This is best explained by example.  The following HTML code, in an HTML file
that has any current DOCTYPE except the two above...

<!-- A -- B <p>C</p> -->
<!-- D - - E <p>F</p> -->
<!-- G -- H <p >I</p> -->

... should be displayed as empty space, since it consists of three HTML
comments.  However, Firefox displays it as...

C --> I -->

The "-- B <p>" is being misinterpreted as a comment end tag (-->).  This does
not happen in the second comment because of the space between the two hyphens. 
The third comment shows that the misinterpreted ">" does not have to be part of
a valid tag.

Reproducible: Always

Steps to Reproduce:
See 'Details' above.
Actual Results:  
See 'Details' above.

Expected Results:  
See 'Details' above.
The second <!-- ends the first which is correct parsing (it is the first
occurence of -- that ends a comment, not --> ).
See http://www.w3.org/TR/REC-html40/intro/sgmltut.html#h-3.2.4

*** This bug has been marked as a duplicate of 229974 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.