Thunderbird junk mail filter not as good as Mozilla 1.7.x junk mail filter

RESOLVED INCOMPLETE

Status

Thunderbird
General
--
major
RESOLVED INCOMPLETE
13 years ago
10 years ago

People

(Reporter: Andy Strojny, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Today I downloaded 118 email messages with Mozilla email program, but left email
on the server. All but 33 were classified as junk, i.e., 85 were classifed as junk.

I downloaded the same 118 messages with the Thunderbird email progam and all but
100 were classifed as junk, i.e, 18 were classified as junk.

Though I like Thunderbird, unless I can get the junk mail filter to work better,
I will not be able to use it.

Note I transferred my Mozilla profile when I installed Foxfire

Any help or suggestions would be appreciated.

Andy

Reproducible: Always

Steps to Reproduce:
1.  Download email
2.  Allow enabled junk mail controls to work
3.  View result and see that most junk emails not classifed as junk

Actual Results:  
View result and see that most junk emails not classifed as junk


Expected Results:  
Junk emails should be classifed as junk at least as well as done by the Mozilla
1.7.x email program.

Comment 1

13 years ago
It's exactly the same junk mail filter. The difference is due to the training
data : you have to indicate which messsages are missed, or which mail shouldn't
be considered as junk. That will improve the filter. 

I think it's possible to migrate the traning data from Mozilla to Thunderbird :
look for a file called training.dat in your profile folder.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> It's exactly the same junk mail filter. The difference is due to the training
> data : you have to indicate which messsages are missed, or which mail shouldn't
> be considered as junk. That will improve the filter. 
> 
> I think it's possible to migrate the traning data from Mozilla to Thunderbird :
> look for a file called training.dat in your profile folder.

(In reply to comment #1)
> It's exactly the same junk mail filter. The difference is due to the training
> data : you have to indicate which messsages are missed, or which mail shouldn't
> be considered as junk. That will improve the filter. 
> 
> I think it's possible to migrate the traning data from Mozilla to Thunderbird :
> look for a file called training.dat in your profile folder.

I just looked for the training.dat files in Mozilla and Thunderbird profiles.
The Mozilla file is 5799kb.  The Thunderbird file is already 6254 kb.  Yet I get
drastically different results as outlined above 
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

13 years ago
(In reply to comment #2)
> I just looked for the training.dat files in Mozilla and Thunderbird profiles.
> The Mozilla file is 5799kb.  The Thunderbird file is already 6254 kb.  Yet I get
> drastically different results as outlined above 

Were those training-data files generated with the same data ? A bigger data-file
doesn't necessarily mean a better filter either. All depends on the traning data
*and* the junk mail itself.

Anyway, the engine is still the same. One of the recent changes was a better
initial training.dat file to help new users, that's all.

BTW: what was the Mozilla version that you aspeak off ?

Updated

13 years ago
Summary: Thuynderbird junk mail filter not as good as Mozilla 1.7.x junk mail filter → Thunderbird junk mail filter not as good as Mozilla 1.7.x junk mail filter
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > I just looked for the training.dat files in Mozilla and Thunderbird profiles.
> > The Mozilla file is 5799kb.  The Thunderbird file is already 6254 kb.  Yet I get
> > drastically different results as outlined above 
> 
> Were those training-data files generated with the same data ? A bigger data-file
> doesn't necessarily mean a better filter either. All depends on the traning data
> *and* the junk mail itself.
> 
> Anyway, the engine is still the same. One of the recent changes was a better
> initial training.dat file to help new users, that's all.
> 
> BTW: what was the Mozilla version that you aspeak off ?


1.7.6 and 1.7.7 and 1.7.8

Comment 5

13 years ago
I'm experiencing this same bug.  I used to use Mozilla Mail 1.7.3, and the junk
filter functined with very high efficiency in this version (and on all previous
versions I used).  Ever since I moved to Thunderbird 1.0.2, the junk filter has
been significantly less efficient at classifying junk mail -- very large numbers
of false negatives (no false positives).  I haved saved all of my junk mail
since 2003 so that I can retrain the filter whenever I need to, so I have a very
large body of junk and non-junk mail on which the filter has been trained.

I completely uninstalled and deleted all configuration files (including
training.dat) for Mozilla 1.7.3 before installing Thunderbird 1.0.2, so I don't
think it should be a conversion problem.  I had Thunderbird produce a completely
fresh training.dat file using my existing large collection of junk mail and
non-junk mail -- the same collection on which I trained Mozilla Mail. 
Thunderbird's filter is definitely not functioning as well for me as Mozilla
Mail's though using the same body of junk and non-junk for training.

Comment 6

12 years ago
Just an update on my experience:

I'm currently using Thunderbird 1.0.6, and I have to say that the junk mail
filtering seems to be working just as well as I remember in Mozilla 1.7.3.  I'm
not really sure what changed, if anything, other than the content of the spam
I've been getting, but I really have no complaints about Thunderbird's junk
filter any more.  As far as I'm concerned, this bug has either disappeared, or
perhaps it never really existed for me to begin with and my mind was playing
tricks on me.
(Reporter)

Comment 7

12 years ago
The junk mail filter in 1.06 only filters about 65% of junk mail, i.e, I get a
100 messages 66 labled as junk.  However about 35 of the remainder are junk. 
Filter is not as good as early version of Mozilla.  

(In reply to comment #6)
> Just an update on my experience:
> 
> I'm currently using Thunderbird 1.0.6, and I have to say that the junk mail
> filtering seems to be working just as well as I remember in Mozilla 1.7.3.  I'm
> not really sure what changed, if anything, other than the content of the spam
> I've been getting, but I really have no complaints about Thunderbird's junk
> filter any more.  As far as I'm concerned, this bug has either disappeared, or
> perhaps it never really existed for me to begin with and my mind was playing
> tricks on me.

Comment 8

12 years ago
Do you have an update for this issue, with a later Thunderbird?  e.g. 1.0.7

See also my comments on related issue (bug 268101)
QA Contact: general

Comment 9

10 years ago
This should be better now in TB 1.5 and 2.0 and reporter appears to be gone, closing incomplete.

That is not to say junk processing does not have its problems, sof you see a problem in 2.0 please check one of the existing bugs.

ref: http://kb.mozillazine.org/Junk_Mail_Controls

Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → INCOMPLETE
Version: unspecified → 1.0
You need to log in before you can comment on or make changes to this bug.