Closed Bug 29427 Opened 20 years ago Closed 20 years ago

nspr doesn't know anything about "make distclean"

Categories

(NSPR :: NSPR, defect, P3)

Other
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: holger, Assigned: wtc)

References

Details

Attachments

(2 files)

... and therefore the included nspr in Mozilla makes it impossible to use "make
distclean" there.


Cure:


Add
  distclean: clean
to nspr's Makefile.



(See also bug #24758)
Status: NEW → ASSIGNED
Reassigned the bug to myself.
Assignee: srinivas → wtc
Status: ASSIGNED → NEW
Attached patch Proposed patch.Splinter Review
I propose that we make distclean a synonym of realclean/clobber_all
to simplify things.
Status: NEW → ASSIGNED
Blocks: 28838
*** Bug 24658 has been marked as a duplicate of this bug. ***
The patch looks good to me.   Is there any particular reason that you don't want
to build pr/tests by default?
We used to build pr/tests by default.  The problem with
that is that as we add more and more tests, it's taking
a long time to build pr/tests.  So we removed pr/tests
from the DIRS list in the top-level makefile.
The patch (attachment 6549 [details] [diff] [review]) has been checked in on the main trunk.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
The previous change to make realclean/clobber_all the same
as distclean is causing problem elsewhere (Bugzilla bug #32467),
so I'm changing it back.

Checked in patch 7279 on the main trunk.
/cvsroot/mozilla/nsprpub/Makefile, revision 3.20
/cvsroot/mozilla/nsprpub/Makefile.in, revision 1.8
/cvsroot/mozilla/nsprpub/config/rules.mk, revision 3.28

So now NSPR has three kinds of clean targets, which
corresponds to the three standard clean targets of
GNU programs as follows:
NSPR                     GNU
clean/clobber            mostlyclean
realclean/clobber_all    clean
distclean                distclean

Note that "clean" means different things in
NSPR and GNU.
The fix for this bug has been merged into the
NSPRPUB_CLIENT_BRANCH and NSPRPUB_RELEASE_4_0_BRANCH.
Target Milestone: --- → 4.0.1
Version: 3.0 → 4.0
Target Milestone: 4.0.1 → 4.0.2
You need to log in before you can comment on or make changes to this bug.