Closed Bug 294284 Opened 16 years ago Closed 16 years ago

Questia.com home page -- A scrollbar overlaps text and a table

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 187435

People

(Reporter: miles.lane, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I tested this page with both Safari and Firefox 1.0.4.  The scrollbar only
appears in Firefox.  Weirdly, there appears to be no reason for a scrollbar to
be displayed.

Reproducible: Always

Steps to Reproduce:
1. Load http://www.questia.com
2. Log into an account (at least, it happens with my account)

Actual Results:  
The scrollbar is rendered on top of text and a table in the middle of a page.

Expected Results:  
As far as I can tell, there is no need for the scrollbar to be rendered.
You are seeing this
<div id="needAStudyBreakContent" style="position:absolute; width:560px;
height:530px; z-index:10; padding: 2px; background-color: #FFFFFF; border: thick
solid #8793A2; left: 187px; top: 314px; visibility: hidden;
overflow:auto;"><link href="/contests/css/questiaContestBeLoudLandingPage.css"
rel="stylesheet" type="text/css"><div align="right"><a href="#"
onClick="MM_showHideLayers('needAStudyBreakContent','','hide')">close
window</a>&nbsp;&nbsp;&nbsp;<br></div>

about three quarters of the way down the source. I suspect that that the site 
has been edited by hand, and maybe this was meant to have been removed.

Do you want a test case?
Hmm.  The scrollbar is displayed whether or not I am logged in.

I tested this with Firefox 1.0.4 on Linux X86 (Debian Unstable) and could not
reproduce the problem.  The problem appears to be specific to OS/X (I am running
OS/X 10.3.9).
Summary: When I log in, a scrollbar appears that overlaps text and a table → Questia.com home page -- A scrollbar overlaps text and a table
Ben,

Does this mean that Firefox is doing the right thing in displaying the
scrollbar?  It is interesting that it only gets displayed on OS/X and not Linux
versions of Firefox 1.0.4.  Is there a way of detecting that the scrollbar
should not be displayed in this case?

Thanks.
FWIW, I can confirm that yanking that stuff out of the HTML does make the
scrollbar go away.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050516
Firefox/1.0+

I should have added that I am using a trunk build. I don't see the scrollbar on

a Linux/X11/x86 1.7.7 build.

I attach my simplified example. The div has visibility: hidden, so you
don't see it, its borders or anything beneath it.

You do see its scroll bars. (overflow: auto)

This is possibly a bug, and possibly Mac OS X only. See Bug 287385 "Div of 
the PARENT DOCUMENT positioned absolute over an IFRAME are displayed under 
the iframe scrollbar"

If this is a bug, then the testcase could be reduced to something
much smaller.
I reproduced the bug with last night's Nightly build for OS/X.
In fact, with this build I get two scrollbars showing up in the middle of the page.
Here's another website that is displaying a scrollbar in the middle of the page.
 Is this the same problem?

http://www.ci.seattle.wa.us/util/Services/Recycling/Recyclable_Items/index.asp
Again, the Safari browser does not display the scrollbar.

*** This bug has been marked as a duplicate of 187435 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.