Toolbar: expand/collapse menu becomes ineffective if grippy used

RESOLVED FIXED in M18

Status

()

Core
XUL
P4
normal
RESOLVED FIXED
19 years ago
18 years ago

People

(Reporter: Marko Macek, Assigned: David Hyatt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT])

(Reporter)

Description

19 years ago
If a toolbar is in a collapsed state, the View|Toolbars|... command will not
cause a relayout and repaint.

Works fine when toolbar is not collapsed.

Build ID: 20000222308 (and others)
Actual bug description (as I see it):

If you collapse a toolbar using the UI controls, the tick on the menu 
remains, and the menu controls then become ineffective. If you click on them, 
the tick appears and disappears, but otherwise there is no effect on the UI. If 
you reexpand the toolbar using the grippy, the menu items start working again.

This is on W95 2000022608.

This is probably yet another corner case of Bug 10278.

Gerv
*** Bug 29430 has been marked as a duplicate of this bug. ***
*** Bug 29430 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: hide collapsed toolbar doesn't repaint → Toolbar: expand/collapse menu becomes ineffective if grippy used

Comment 4

18 years ago
This is WORKSFORME on win32 moz trunk build 2000032408.  Marko.Macek@gmx.net
could you download a current build and try this again.

Comment 5

18 years ago
updating component and owner.
Assignee: cbegle → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: asadotzler → jrgm

Comment 6

18 years ago
reproduced on Linux. assigning to evaughan as p4 for m17
Assignee: trudelle → evaughan
Priority: P3 → P4
Target Milestone: --- → M17
This is still not working right on W95 (20000324). Menus and collapse-me bars 
are not connected in the right way, and can easily be got out of sync. 

Gerv

Comment 8

18 years ago
Mass moving M17 bugs to M18
Target Milestone: M17 → M18
I believe this is the correct way of nominating a bug for consideration by PDT, 
but I'm not sure... If this isn't a dupe, it needs fixing for nsbeta2. The 
menu/grippy link is still broken in 20000428.

Gerv
Whiteboard: [PDT]

Comment 10

18 years ago
see bug 35181

Comment 11

18 years ago
Toolbars were rewritten in XBL by hyatt. He probably already has a bug on this.
Assignee: evaughan → hyatt
(Reporter)

Comment 12

18 years ago
This seems to be fixed both on Linux and Windows.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.