Closed Bug 294326 Opened 19 years ago Closed 19 years ago

cancelling news msg for second time doesn't generate alert if you're not the poster

Categories

(MailNews Core :: Networking: NNTP, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.8beta3

People

(Reporter: kiran.s, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514

Newsgroup account fails to pop up alert message, when you try to cancel the
message from the account not belonging to you for the second time.

Reproducible: Always

Steps to Reproduce:
1. Open Mozilla web Browser.
2. Open Mail and Newsgroups from Status Bar.
3. Click on a Newsgroups account on the left panel to open it.
4. Under messages window, select a message that does not belong the account you
are looking at.
5. Right click on the selected message and choose "Cancel Message".
6. This gives an alert "This message does not appear to befrom you". Now click
on 'OK' to close the alert.
7. Now again right click on the same message that we tried to cancle in step 3
and again choose "Cancel Message".

Actual Results:  
No Alert pops up as in step 6 and the window is bussy for ever and can be
stopped by pressing 'Esc'. Now the account cannot be used to view any message,
unless clicked on a different account or resetting the account again.


Expected Results:  
The popup Alert should come each and every time I try to cancel the message of
somebody's news account.

This problem is seen with the latest mozilla browser apart from the one on which
the problem is reported i.e Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7) Gecko/20040514.
Attachment #183718 - Flags: review?(neil.parkwaycc.co.uk)
This bugs is in core and affects TB too. If so, you should correct to select the
right product. Also, it would be more adequate to ask bienvenu/mscott/sspitzer
if they approve this way of correcting it, neil is not peer on the news specific
code.

In the for comments of the patch, either you don't wrap line at all, or you must
wrap them under 80 characters. In that case, it's clearly too long for only one
line, so please wrap at 80 characters.
Status: UNCONFIRMED → NEW
Component: MailNews: Notification → Networking: IMAP
Ever confirmed: true
OS: Windows XP → All
Product: Mozilla Application Suite → Core
Version: unspecified → Trunk
Oups, wrong selection in the list. If you think you will be able to provide more
patch like this one in the future, try to ask for the rigt to open bugs as new.
Component: Networking: IMAP → Networking: News
Comment on attachment 183718 [details] [diff] [review]
Patch fixing the bug

I'll try to look at this tomorrow.
Attachment #183718 - Flags: superreview?(bienvenu)
changing summary - I'll try this patch right now.
Summary: Newsgroup-Account-not working properly → cancelling news msg for second time doesn't generate alert if you're not the poster
Comment on attachment 183718 [details] [diff] [review]
Patch fixing the bug

good one, thx for the fix.
Attachment #183718 - Flags: superreview?(bienvenu) → superreview+
Comment on attachment 183718 [details] [diff] [review]
Patch fixing the bug

Backend bug -> try mscott for review
Attachment #183718 - Flags: review?(neil.parkwaycc.co.uk) → review?(mscott)
Attachment #183718 - Flags: review?(mscott) → review+
Comment on attachment 183718 [details] [diff] [review]
Patch fixing the bug

It' small, low risk and useful. It would be good to land it now.
Attachment #183718 - Flags: approval1.8b3?
Attachment #183718 - Flags: approval1.8b3? → approval1.8b3+
bienvenue, can you check it in ?
fixed on trunk, thx, Jean-Marc
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
*** Bug 105317 has been marked as a duplicate of this bug. ***
The wrong person was attributed in the checkin comment.

Actual patch was by kiran.s@in.ibm.com
ah, sorry, Kiran. Thx for the fix
Sorry Kiran for the wrong attribution in the cvs check-in. 
When I saw your bug initially I thought it was great that you reacted by
providing a patch, but that you needed some help to get it included or it was at
risk of lingering forever. So I pushed it all along, but I didn't realise this
meant a risk bienvenu would be confused about who's patch it was.

Given the opportunity I'd do it against because when you follow the right steps
it's not as hard as some believe for a newcomer to get a small patch included,
but I'll take care about that point.
Nice to see this bug fixed, after I filed it back in 2001 ;-)

Verified FIXED using build 2005-06-09-06, Seamonkey trunk WinXP.
Status: RESOLVED → VERIFIED
QA Contact: stdonner
Hardware: PC → All
Target Milestone: --- → mozilla1.8beta3
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: