Zombie processes cause crashes

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Timothy Miller, Unassigned)

Tracking

({crash})

1.7 Branch
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050301
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050301

For whatever reason, I get zombie Mozilla processes from time to time.  When
that happens, Mozilla becomes extremely unstable, crashing frequently after only
minutes of usage.  I can't seem to find a way to get rid of the zombies.  After
I reboot, Mozilla is fine until the zombies come back and then it gets unstable
again.  I don't know what's causing the zombies, but surely that shouldn't cause
Mozilla to crash.

Reproducible: Sometimes




Note:  I'm leaving this as "normal" because the zombies don't appear on a
regular basis.

Comment 1

13 years ago
Uh, if there aren't any steps to reproduce (or something like that), this is
likely to be invalid.

Comment 2

13 years ago
> I don't know what's causing the zombies, but surely that shouldn't cause
> Mozilla to crash.

It's likely the same thing that causes the zombies also causes the crash.
Try a clean profile, removing extensions, plugins, etc.
Keywords: crash
Version: unspecified → 1.7 Branch
(Reporter)

Comment 3

13 years ago
I've been working on this, and I think I have found what's going on.  I'm using
a MUD client called "Trebuchet" that is a Tcl/Tk program.  If you tell it to
open a URL in a browser window, and then you close the browser, it leaves a
zombie process lying around until you close Trebuchet.  Now, I don't know why
the zombie process is hanging around, because I'm pretty sure that mozilla's
binary is launched through a script, and it's not the shell process that is the
zombie.  But in any event, now we know the chain of events that lead up to the
zombie, and we know that Mozilla isn't responsible for creating the zombie.  The
odd thing is that with that zombie hanging around, Mozilla launches and runs
okay for several minutes before crashing.  I'm not sure that an unrelated zombie
process (or anything for that matter) is a good excuse for Mozilla to crash. 
Perhaps Mozilla is attempting some IPC and mistakenly identifies the zombie as
another Mozilla process.  When doing that, shouldn't Mozilla make sure that the
other process it found isn't a zombie?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 5

13 years ago
This bug still persists.  I had to switch over to using Konqueror whenever I
launched a browser from Trebuchet, because it doesn't have that problem.

Comment 6

10 years ago
Don have similar problems several months with trunk builds, WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.