Windows 2000 not detected properly

VERIFIED DUPLICATE of bug 39918

Status

()

Bugzilla
Bugzilla-General
P3
normal
VERIFIED DUPLICATE of bug 39918
18 years ago
5 years ago

People

(Reporter: Jerry Baker, Assigned: justdave)

Tracking

Details

(Reporter)

Description

18 years ago
Using NC 4.72, which has user-agent support for Windows 2000, Bugzilla does not 
properly recognize Windows 2000. Bugzilla sees the user-agent as Mozilla/4.72 
[en] (Windows NT 5.0; U), but it initializes the OS as "Other".

Comment 1

18 years ago
Now it's being detected as "Windows NT" and not "Windows 2000".
My UA: Mozilla/4.72 [en] (Windows NT 5.0; U)

Comment 2

18 years ago
Shouldn't it be enough to replce these two in enter_bug.cgi:
/Mozilla.*\(Windows.*NT/        && do {return "Windows NT";};
/Mozilla.*Windows NT 5.*\)/     && do {return "Windows 2000";};

to:
/Mozilla.*\(Windows.*NT 5.*/        && do {return "Windows 2000";};
/Mozilla.*\(Windows.*NT/        && do {return "Windows NT";};
/Mozilla.*Windows NT 5.*\)/     && do {return "Windows 2000";};

Comment 3

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara

Comment 4

18 years ago
this was fixed already

*** This bug has been marked as a duplicate of 39918 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
moving to Bugzilla product
reassign to default owner/qa for INVALID/WONTFIX/WORKSFORME/DUPLICATE
Assignee: tara → justdave
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
QA Contact: matty
Version: other → unspecified
(Reporter)

Comment 7

16 years ago
Mass removing self from CC list.
(Reporter)

Comment 8

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.