Scrolling the <SELECT> impossible when custom CSS set for OPTION

RESOLVED DUPLICATE of bug 163503

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 163503
13 years ago
13 years ago

People

(Reporter: Scyld, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)

Try to scroll down <SELECT> from this example:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
  <title>SELECT bug</title>
  <meta>
  <style type="text/css">
#prodList option:hover {
  text-decoration: underline;
  font-style: italic;
}
select {
  width: 120px;
}
  </style>
</head>
<body bgcolor="#ffffff">
<form name="manufacturers" action="/index.php" method="get"> <select
name="manufacturers_id" onChange="this.form.submit();" id="prodList" size="10">
<option value="53">Acid Jazz</option> <option value="54">Acuarela</option>
<option value="55">Avatar</option> <option value="56">Chocolate
Fireguard</option> <option value="57">Cooking Vinyl</option> <option
value="73">Different Records</option> <option value="58">Downsall
Plastics</option> <option value="59">Dualtone</option> <option
value="71">Essential</option> <option value="60">Europa</option> <option
value="72">Exceptional</option> <option value="61">Fat City Recordings</option>
<option value="62">Final Traffic</option> <option value="68">Good
Records</option> <option value="63">Grand Central</option> <option
value="75">GRIT Records</option> <option value="69">Intact</option> <option
value="76">KITTY YO</option> <option value="64">Manifesto</option> <option
value="77">Meganite</option>
<option value="65">MumboJambo</option>
<option value="78">Pure Music</option>
<option value="79">Scenario</option>
<option value="66">Silverline</option>
<option value="80">Sula Records</option>
<option value="67">Surprise</option>
<option value="81">Transparent</option>
<option value="82">Trust the DJ</option>
<option value="70">U-Watch Records</option>
<option value="74">Union Square Music</option>
</select></form>
  </tr>
</body>
</html>

Reproducible: Always

Steps to Reproduce:

*** This bug has been marked as a duplicate of 163503 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Created attachment 183772 [details]
Reporter's testcae taken from comment 0

I see the described behaviour with Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.8b2) Gecko/20050516 Firefox/1.0+ ID:2005051613
You need to log in before you can comment on or make changes to this bug.