[FIX]onChange() handler on select object not being fired

VERIFIED FIXED in M16

Status

()

P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: xtim, Assigned: rods)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in my tree)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
The onChange() handler is only being fired when the mouse is used to select an
item.  The onChange handler is not being fired when the keyboard is used.  Using
MSIE it fires in both instances.

Comment 1

19 years ago
xtim, do you have a test case handy? What build(s) show this problem?

Thanks :)
(Reporter)

Comment 2

19 years ago
Created attachment 5836 [details]
Tiny tar file with HTML to demonstrate problem

Comment 3

19 years ago
Probem demonstrated in file, bug confirmed, marking as NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

19 years ago
xtim@cobber.com are you still seeing this problem with current builds?

Comment 5

19 years ago
updating component and owner.
Assignee: cbegle → joki
Component: Browser-General → Event Handling
QA Contact: asadotzler → janc

Comment 6

19 years ago
comments from reporter via email:

This bug is present in M14 it is also present in the latest Linux build that I
  can run
  2000-03-21-09-M15. This one also seems to have numerous other problems which I
  assume
  are the result of work in progress.

  Regards,

  Tim.
(Reporter)

Comment 7

19 years ago
This bug still exist in build of Mar 27.  The application appears to have 
regressed in other ways since M14 but the specific problem reported and 
demonstrated in the attachment still exist.

Comment 8

19 years ago
Rod, seems like this would be yours.
Assignee: joki → rods
(Assignee)

Comment 9

19 years ago
mass-move to M16
Target Milestone: --- → M16
(Assignee)

Comment 10

19 years ago
Please attach an html example I haven't been able to open the tar file.

Comment 11

19 years ago
Created attachment 7807 [details]
HTML file demonstrating the problem
(Assignee)

Comment 12

19 years ago
Fix is in my tree
Status: NEW → ASSIGNED
Summary: onChange() handler on select object not being fired → [FIX]onChange() handler on select object not being fired
Whiteboard: fix in my tree
(Assignee)

Comment 13

19 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 14

19 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 15

18 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 17

18 years ago
QA contact updated
QA Contact: gerardok → madhur

Comment 18

17 years ago
verified on build 2001-08-06-03-trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.