text-transform applies inconsistently on SELECT OPTIONS

RESOLVED DUPLICATE of bug 79107

Status

()

RESOLVED DUPLICATE of bug 79107
14 years ago
5 years ago

People

(Reporter: joelgrimes, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050516 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050516 Firefox/1.0+

The style text-transform applied to a SELECT/OPTION does not act on the options
unless the dropdown is activated.  The current option displayed in the select
disregards the style.

Reproducible: Always

Steps to Reproduce:
1. Create a select with the style="text-transform:uppercase" applied to the OPTIONS
2. 
3. 

Actual Results:  
The first select does not respect the text-transform style in the currently
selected option.  It is not uppercase

Expected Results:  
Style should be applied to the currently selected option.  Should be uppercase
in both the drop-down list and the currently selected value. 

If the style is applied to the SELECT rather than the options, the problem is
not seen.
(Reporter)

Comment 1

14 years ago
Created attachment 183787 [details]
testcase
Keywords: testcase
The combobox in general doesn't "show the selected option"; it just shows its
value.  We have existing bug reports about this (eg the color and such of the
selected option is also not shown when the combobox is closed).
Whiteboard: DUPEME

Comment 3

10 years ago
(In reply to comment #2)
> The combobox in general doesn't "show the selected option"; it just shows its
> value.  We have existing bug reports about this (eg the color and such of the
> selected option is also not shown when the combobox is closed).

That's bug 79107.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 79107

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.