[si, si-LK] Sinhala: Firefox, Thunderbird

RESOLVED FIXED

Status

Mozilla Localizations
Registration & Management
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: Rohana Dasanayaka, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: needs-pike, aka sinhala)

Attachments

(3 attachments, 11 obsolete attachments)

149.96 KB, application/x-bzip
Pike
: review+
Details
27.69 KB, patch
Details | Diff | Splinter Review
199.88 KB, application/x-gzip
Pike
: review+
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910

New Mozilla Localization Project (si-LK)
singhalese- SRI LANKA

Contributors : 
Rohana Dasanayaka (rohana@accmt.ac.lk)
Kumudini Amaradasa (kumudini@accmt.ac.lk)

http://www.accimt.ac.lk/mlp/

Products: Mozilla Thunderbird, Mozilla Firefox

Contact Address:
Arthur C Clarke Institute for Modern Technologies,
Katubedda, Moratuwa,
SRI LANKA


Reproducible: Always

Comment 1

13 years ago
Rohana, could you please comment with a status report of your localisation?
Also, is there a typo on your last name here, or on 
http://www.accimt.ac.lk/it/itourteam.htm?
In order to commit localization of Firefox or Thunderbird you need to apply
for CVS account - see bug 263726 as an example. And you should also provide your
localization files to review.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: New Mozilla Localization Project (si-LK) → Registration of Singhalese (si-LK) localization of Firefox and Thunderbird
(Reporter)

Comment 3

13 years ago
Created attachment 192351 [details]
Firefox Language pack , si-LK
(Reporter)

Comment 4

13 years ago
Created attachment 192353 [details]
Thunderbird Language Pack
(Reporter)

Comment 5

13 years ago
(In reply to comment #2)
> In order to commit localization of Firefox or Thunderbird you need to apply
> for CVS account - see bug 263726 as an example. And you should also provide your
> localization files to review.

Pl. find the attched files which are language pack for Firefox and Thunderbird.
These  files are actually for older versions.

Updated

13 years ago
Attachment #192353 - Attachment is patch: false
Attachment #192353 - Attachment mime type: text/plain → application/x-xpinstall

Comment 6

13 years ago
(In reply to comment #1)
> Also, is there a typo on your last name here, or on 
> http://www.accimt.ac.lk/it/itourteam.htm?

Looking at that page again, it seems like the typo was over there.

Rohana, we'd need a source localization, and we'd need to know what you localized.
The review will be needed to find out what needs to be done to get a working 
build, language packs are only good for finding out how you localized, which 
would require some singhalese language skills on our side.

If you're not sure what to tackle, we prefer trunk localizations now, as the
structure between aviary and trunk changed a bit and you'd need to port your
localization twice.
Depends on: 304941
Summary: Registration of Singhalese (si-LK) localization of Firefox and Thunderbird → [si-LK] Singhalese: Firefox, Thunderbird
On behalf of the Mozilla Project, I'd like to apologise for the delay in processing this request. We very much appreciate offers of help in localization.

If anyone reading this is still interested in helping to translate one or more Mozilla products into the language that this bug is about, please add a new comment to this bug to confirm your interest, saying again which products you would like to localize e.g., Firefox, Thunderbird. We will then make the necessary arrangements.
(Reporter)

Comment 8

11 years ago
We actually localized language packs for Firefox 2.0 and Thunderbird. Now we need your help to start source localization. We are very keen to do it and introduce fully localized version in "Sinhala" language. Your help in this regard is highly appreciated.
Great :-) You need to read this wiki page:
http://wiki.mozilla.org/L10n:Starting_a_localization

Create yourself a wiki page for your localisation, which registers you as the team for that language. Then, follow the instructions on the wiki to produce a language pack you can distribute through addons.mozilla.org. Once you have reached that stage, we can consider your pack for official status - although I should warn you that this is a separate process with its own complexities. Still, the community will still be able to get your pack from addons.mozilla.org in the meantime.

If you have read carefully and find the documentation isn't good enough in any way, please let us know and we will improve it.

Gerv

Comment 10

11 years ago
To add here, the process from a source to a langpack is lossy, so reverting that requires a tad of additional work. But there is a tool that Cedric did, a french localizer, that does the mechanical part of the work. Find more information and the script at http://perso.orange.fr/cedric.corazza.net/html/langpack2cvstree.html.

Thanks for your patience, and if there are open questions, ask ahead, either here, or in the l10n newsgroup, mentioned on http://wiki.mozilla.org/L10n:Localization_Process_Start.

Comment 11

11 years ago
Dear Rohana,

At the moment I'm working on Localization of the Fedora, Gnome and OpenOffice. (http://fedoraproject.org/wiki/DanishkaNavin)
I would like to actively participate Firefox/Thunderbird 3 Localization for Sinhala (si-LK).
Pls assist me to have cvs access for the Firefox/Thunderbird 3 Localization.

http://groups.google.com/group/mozilla.dev.l10n.in/browse_thread/thread/c8912794110f9e7f/3dde337961684274#3dde337961684274

Regards'
Danishka Navin

Updated

11 years ago
Whiteboard: aka sinhala

Comment 12

10 years ago
Created attachment 292053 [details]
Sinhala (si-LK)  translation for the  Firefox 2 - Part !

Sinhala (si-LK)  translation for the  Firefox 2 consist with two files (due to uploading limit I created my translation in to two files) 
Firefox2-translation-si-LK_Part-1.tar.bz2 and
Firefox2-translation-si-LK_Part-2.tar.bz2

attached Firefox2-translation-si-LK_Part-1.tar.bz2 by Danishka Navin

Comment 13

10 years ago
Created attachment 292054 [details]
Sinhala (si-LK)  translation for the  Firefox 2 - Part 2

Sinhala (si-LK)  translation for the  Firefox 2 consist with two files (due to
uploading limit I created my translation in to two files) 
Firefox2-translation-si-LK_Part-1.tar.bz2 and
Firefox2-translation-si-LK_Part-2.tar.bz2

attached Firefox2-translation-si-LK_Part-2.tar.bz2 by Danishka Navin

Comment 14

10 years ago
Created attachment 292055 [details]
Sinhala (si-LK)  language packfor the  Firefox 2 - Part 2

Sinhala (si-LK)  language pack for the  Firefox 2

Comment 15

10 years ago
Hi Gervase / Pike,

I didn't get any response for my previouse comment on 2007-10-04.
I have translated the Firefox 2 for Sinhala language and attaching my translation, language-pack and few
 screenshots for your convenience.

I would like continue my work with the Mozilla, for further contribution pls let me know how to go ahead with CVS access.

Regards,

-- 
Danishka Navin 

Comment 16

10 years ago
sorry..
Unable to upload at least Single screenshot due to its file size.


Regards,
Danishka

Comment 17

10 years ago
Hrm. What is the '!' attachment? I'm not really sure what I'd have to download here.

As a tip, if you have en-US.aff and en-US.dic in extensions/spellcheck/myspell, you might want to remove those, shipping the en-US dictionary doesn't make a whole lot of sense, and not having those reduces your upload size considerably.

Once you cleared up what I should really look at, mind setting the 'r' flag on the attachment to '?', and enter l10n@mozilla.com as requestee? That way, that ends up on my review queue.

Regarding #15, we don't need screenshots or the like now, and http://wiki.mozilla.org/L10n:Teams:si-LK looks good in terms of exposing your team.

Setting dependency to the cvs account bug, too, so that we know which is which.
Blocks: 407648

Comment 18

10 years ago
Created attachment 292540 [details]
Firefox2 translation for Sinhala (si-LK) - "complete translation"

Firefox2 translation for Sinhala (si-LK) - "complete translation"

Comment 19

10 years ago
Created attachment 292545 [details]
Firefox2 translation for Sinhala (si-LK) - "Final Translation"

Firefox2 translation for Sinhala (si-LK) - "Final Translation"
Attachment #292545 - Flags: review?(l10n)

Comment 20

10 years ago
Hi Pike,

Reattached the Sinhala final translation and pls find it using following link. https://bugzilla.mozilla.org/attachment.cgi?id=292545


Danishka

Updated

10 years ago
Attachment #292053 - Attachment is obsolete: true

Updated

10 years ago
Attachment #292054 - Attachment is obsolete: true

Updated

10 years ago
Attachment #292055 - Attachment is obsolete: true

Updated

10 years ago
Attachment #292540 - Attachment is obsolete: true

Comment 21

10 years ago
Created attachment 292561 [details]
Firefox langpack for  Sinhala (si-LK)

Comment 22

10 years ago
Added Firefox language pack for Sinhala (si-LK)
https://bugzilla.mozilla.org/attachment.cgi?id=292561

Comment 23

10 years ago
Hi Gervase, Pike & Danishka,

I am Kasun from University of Moratuwa, Sri Lanka. I would like to join with Thunderbird localization. I have spoken with accimt people and joined with them. XPI for the thunderbird which we have now (www.lakapps.lk/si-LK-tb.xpi) is finished up to 90% (still there are some words to be localized with the support of language specialist) and I am willing to contribute with source development.

Thanks and Regards,

Kasun Karunaratne
(Reporter)

Comment 24

10 years ago
Created attachment 292748 [details]
si-LK Language Pack for Thunderbird 2.0.0.x

This is the si-LK language pack for Thunderbird 2, and it is developed with the help of Kasun Karunarathne. The latest pack is available at www.lakapp.lk.

Comment 25

10 years ago
Hi Danishka,

I have just tested firefox language pack & it's running perfectly. I think you should get the CVS access to submit your translations into the CVS repository. Please give me the bug id for the CVS account you filed. I will vouche for you...

Comment 26

10 years ago
Danishka,

I think the bug summary contains wrong language name. It should be "sinhala" or "sinhalese" instead of "singhalese"... Please correct the summary, if it's wrong...

Comment 27

10 years ago
Hi Ankit,

I have already created the bug to get CVS access.
My bug id is # 407648.

Thanks 

Comment 28

10 years ago
Comment on attachment 292545 [details]
Firefox2 translation for Sinhala (si-LK) - "Final Translation"

Looking at this, there are a bunch of errors. While looking at the errors in particular, I saw some interesting mixes between English and non-English within single sentences. I really only looked in dom, so take a look at those files again?

I'll attach a compare-locales output, most of those errors come from grammar errors in the files. Quite often, there was a UTF-8 BOM, please don't add those, and then there were a few missing newlines, too.

You probably want to run compare-locales, locally, just documented that a bit, http://developer.mozilla.org/en/docs/Compare-locales (comments welcome)
Attachment #292545 - Flags: review?(l10n) → review-

Comment 29

10 years ago
Created attachment 293653 [details]
output of compare-locales

Comment 30

10 years ago
Created attachment 294470 [details]
Corrected final translaltion of Firefox 2.x into Sinhala (si-LK)

Hi Pike,

I have corrected all the errors you mentioned... I run the compare-locales si-LK > diff on the latest MOZILLA_1_8_BRANCH & checked... It looks correct to me...

Btw, I removed english dictionary as well...

Please check the latest source & let me know, if something else needs to be corrected.
Attachment #292545 - Attachment is obsolete: true
Attachment #294470 - Flags: review?(l10n)

Comment 31

10 years ago
Sorry for the lag here.

Pascal just poked me with out font problems for Singhalese. I filed a bug for locales like that, bug 411129.

Given that we have dependencies on being able to release this that may or may not resolve quickly, would it be way evil if we pushed this one back to Firefox 3? We'll already have a hard time releasing the localizations already in the queue, so this might not be too bad. We have language packs on AMO now, linked to from all.html, too, which could add information on fonts on the download page, I guess. 

That said, I did look at the source, and it's mostly good, I only found a few nits, region.properties looks a tad funky with the second search engine (should be just Yahoo), Google Reader should be just Google these days, bookmarks.html would need adjusted links, the .xml files in searchplugins aren't needed (list.txt is, though).

I'd like to chat about the locale code, too. We're favoring short ones over full ones, i.e., "si" over "si-LK", unless the "-LK" really marks a lingustic variant. So if you don't mind, we'd rather use just "si".

Sorry again for the lag, still catching up with my backlog of holidays.
Depends on: 411129

Comment 32

10 years ago
Hi Alex,

I'm ok with both 'si' as well as 'si-LK' as the locale code.
I don't have any issue with language code.
So, shall we go ahead with the lang-code 'si'.

 

Comment 33

10 years ago
Comment on attachment 294470 [details]
Corrected final translaltion of Firefox 2.x into Sinhala (si-LK)

r=me with comments. There were still a bunch of errors, which I took the freedom to just fix. I left one for you, the values for the following error will need to be in one line per translated string,

si/dom/chrome/layout/css.properties
    ERROR: Unparsed content " සඳහා අනන්‍යකාරකයක් බලාපොරොත්තු වුවත් ලැබුනේ '%1$S'.
" at 4077-4130
    ERROR: Unparsed content " හෝ namespace වුවත් ලැබුනේ '%1$S'.
" at 4195-4230

I'll attach a patch for the changes I did.

I replaced region.properties and list.txt with their en-US trunk versions, I fixed the links in bookmarks.html, and I removed the search engines, as those weren't needed. Just as the remaining files from the myspell dictionary.

I'll do the initial landing and then head over to the cvs account bug.

Congrats, and sorry for the lag again.
Attachment #294470 - Flags: review?(l10n) → review+

Comment 34

10 years ago
Created attachment 301884 [details] [diff] [review]
changes done before landing
Attachment #192351 - Attachment is obsolete: true
Attachment #292561 - Attachment is obsolete: true
Attachment #293653 - Attachment is obsolete: true

Comment 35

10 years ago
Marking FIXED, wiki is updated, follow up bugs are filed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Summary: [si-LK] Singhalese: Firefox, Thunderbird → [si, si-LK] Sinhala: Firefox, Thunderbird
(Reporter)

Comment 36

10 years ago
Created attachment 306707 [details]
Sinhala Translation for Thunderbird 2

This is the source files of sinhala translation for Mozilla Thunderbird 2. Used "Cedric's tool" and compare-locale.pl to test this.

The relevant language pack for this is available at (size 314 KB) http://www.accimt.ac.lk/sinhala/download/si-LK-tb.xpi

Need help to check in to the CVS repository.
Attachment #192353 - Attachment is obsolete: true
Attachment #292748 - Attachment is obsolete: true
Attachment #306707 - Flags: review+

Updated

10 years ago
Whiteboard: aka sinhala → needs-pike, aka sinhala

Updated

10 years ago
Blocks: 416131
(Reporter)

Updated

10 years ago
Attachment #306707 - Flags: review+

Updated

10 years ago
Blocks: 420442
(Reporter)

Comment 37

10 years ago
Created attachment 310448 [details]
Latest Sinhala Translation for Thunderbird 2  

More translated strings in new one
Attachment #306707 - Attachment is obsolete: true
Attachment #310448 - Flags: review?(l10n)
(Reporter)

Comment 38

10 years ago
Dear Danishka,

Could you please give some info about the Sinhala localization on Firefox 3. We are using a ("partly translated") Sinhala Language Pack which works with Beta5. What kind of collaboration you may need to prepare Sinhala localization. We will be able to help you to do this in order to release "Sinhala Firefox" as it release.

Thanks,
Rohana.

Updated

10 years ago
Blocks: 439247

Comment 39

10 years ago
Comment on attachment 310448 [details]
Latest Sinhala Translation for Thunderbird 2  

This was already landed in bug 439247, noting the review here anyway.
Attachment #310448 - Flags: review?(l10n) → review+
You need to log in before you can comment on or make changes to this bug.