Bugs can show up multiple times in a dependency tree

RESOLVED DUPLICATE of bug 181076

Status

()

Bugzilla
Bugzilla-General
--
trivial
RESOLVED DUPLICATE of bug 181076
13 years ago
13 years ago

People

(Reporter: Waldo, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
At the time this bug was filed, the referenced URL showed the following:

Bugs that bug 289480 depends on
( view as bug list | change several)

    * 1156 [mozilla1.9alpha, cbiesinger@gmx.at] -OBJECTs without type attribute
aren't rendered.
    * [-] 96976 [---, peterl-bugs@peterl.com] -Alternate content of IFRAME and
OBJECT elements isn't displayed when data/src unreachable.
          o 1156 [mozilla1.9alpha, cbiesinger@gmx.at] -OBJECTs without type
attribute aren't rendered.
          o [-] 96579 [Future, peterlubczynski-bugs@peterl.com] -<object> with
absolute URL and without MIME type doesn't work.
                + 1156 [mozilla1.9alpha, cbiesinger@gmx.at] -OBJECTs without
type attribute aren't rendered.
                + [-] 95549 [Future, jst@mozilla.org] -OBJECT tag: Content-type
header should take precedence.
                      # 1156 [mozilla1.9alpha, cbiesinger@gmx.at] -OBJECTs
without type attribute aren't rendered.
                + 157554 [mozilla1.3beta, peterl-bugs@peterl.com] -Failure to
instantiate plugin in nsPluginStreamListenerPeer::OnStartRequest does not cause
us to layout alternate renderings.
          o 157554 [mozilla1.3beta, peterl-bugs@peterl.com] -Failure to
instantiate plugin in nsPluginStreamListenerPeer::OnStartRequest does not cause
us to layout alternate renderings.
[rest omitted]

Note that bug 1156 is repeated in this list several different times.  Dependency
trees are to the best of my knowledge supposed to show the usual "this bug is
elsewhere in the tree" thing, but this list isn't showing it.

This is admittedly trivial, particularly as showing bug 1156 multiple times
isn't breaking by looping, but it's still a bug.
Currently, the "this bug is elsewhere in the tree" note will be shown only if
the duplicated bug has dependencies itself.

*** This bug has been marked as a duplicate of 181076 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.