Stylesheet width parameter not respected

VERIFIED DUPLICATE of bug 34415

Status

()

VERIFIED DUPLICATE of bug 34415
14 years ago
14 years ago

People

(Reporter: deboer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

The stylesheet width parameter is not respected for the <span> element. The
following sample should contain a box that spans the entire width of the page,
but the width parameter is ignored and the box is only big enough to contain the
word "Hello".

<html>
<body>
The following line should span the entire page:<br/>
<span style="background-color: black; width: 100%; color: white;">Hello</span>
</body>
</html>

Reproducible: Always

Steps to Reproduce:
1. Copy and paste the HTML above into a file.
2. Open it with Firefox, and the box does not span the entire page.
3. Open it with IE (ouch) or another browser and the box does.
Actual Results:  
Box is compressed along the left side of the page.

Expected Results:  
The box should span the entire width of the web page.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 34415 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.