crash at startup because of huge number of xul windows being opened [@ 0x00000001] [@ nsPlaintextEditor::CanPaste]

RESOLVED WONTFIX

Status

()

Core
Editor
--
critical
RESOLVED WONTFIX
13 years ago
7 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
I installed a XPI file:
ftp://ftp.netscape.com/pub/netscape8/english/8.0/windows/win32/xpi/remotedataso
urces.xpi
that caused the global browser.xpi to be replaced. so now when I start firefox 
I get a huge amount of new XUL windows with errors in them and in the end 
firefox crashes.

getting the error windows are fine since the browser.xpi properly contains 
references to unknown files etc, but the crash is not ok.

talkback IDs:
TB5913595M
TB5913373W

Updated

13 years ago
Keywords: talkbackid

Comment 1

13 years ago
Henrik, is this still reproducible? The XPI you linked to no longer works in
current trunk (and branch?) builds.
Keywords: talkbackid
Created attachment 243522 [details]
TB25038222K stack trace 25-Oct-2006

crash @00000001 starting Firefox with 62 tabs using MR-Tech Local Install including Session Saver functionality

"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061025 Firefox/1.5.0.8" - Build ID: 2006102504

Comment 3

12 years ago
I guess we can morph this into a bug to be about Tony's stacktrace. Looks like bug 313975. (We run out of memory since they're so many windows).
Severity: normal → critical
Component: Startup and Profile System → Editor
Keywords: crash
Product: Firefox → Core
QA Contact: startup
Summary: crash at startup because of huge number of xul windows being opened → crash at startup because of huge number of xul windows being opened [@ 0x00000001] [@ nsPlaintextEditor::CanPaste]
Version: unspecified → 1.8 Branch
QA Contact: editor
If you open enough windows to run out of memory, you're going to crash, yes.  That's unlikely to change until we get our entire OOM story in order (see bug 427099 and its dependency tree).

As comment 3 notes, there happens to be a bug report on one specific crash that can happen, but fixing that will probably just reveal another crash.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

7 years ago
Crash Signature: [@ 0x00000001] [@ nsPlaintextEditor::CanPaste]
You need to log in before you can comment on or make changes to this bug.