If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Copying list items to clipboard ignores numbering style

RESOLVED DUPLICATE of bug 136595

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 136595
13 years ago
13 years ago

People

(Reporter: Chris Newton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

On the cited page are several nested lists, some of which are ordered lists that
use the type attribute to control the display of numbering. Copying part of the
page to the clipboard results in the loss of this number formatting information.

Specifically, all numbered items seem to be copied in the style 1, 2, 3...
regardless of the regardless of the type specified on the ol tag and correctly
displayed on-screen.

Possibly related, if the selection starts in mid-list, then the outermost list's
items seem to be prefixed with # characters rather than numbered.

The page does not have a DOCTYPE specified, but I would still expect that text
copied to the clipboard would reflect what was actually displayed on the screen
at the time.

Reproducible: Always

Steps to Reproduce:
1. Open the cited web page.
2. Select some text from within the nested lists.
3. Copy to clipboard.
4. Paste into your text editor of choice and observe the list item markers.

Actual Results:  
All items were labelled in the 1,2,3 style in the clipboard copy, or with #
markers for the outermost list items as described above.

Expected Results:  
All items should have had markers matching what was displayed on the web page
when the information was copied.

*** This bug has been marked as a duplicate of 136595 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.