usemap in image changes entire image to hot area by default

RESOLVED DUPLICATE of bug 90576

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 90576
13 years ago
13 years ago

People

(Reporter: Joseph Myers, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

usemap in image changes entire image to hot area by default--even when there is
no such map defined in the current HTML page.


Reproducible: Always

Steps to Reproduce:
1. Visit the example page: http://www.providenceproject.com/tour/pages/mp1.htm
2. Move the cursor over the main image.


Actual Results:  
The cursor changes to a hand as if ready to activate a link.


Expected Results:  
No hand should appear, since there is no link, and indeed, nothing occurs when
the image is clicked.




There is in fact no <map> corresponding to the name of the usemap associated
with the image. The browser should not then provide the illusion that the image
is a link, when indeed there is no link at all.

It may be that people have heretofore used this bug as a "feature" and invented
nonexisted usemaps in order to change the style of an image so that a hand will
appear on it when the cursor is positioned over it.

If this is the case, then

Comment 1

13 years ago
Created attachment 196288 [details]
very minimal testcase

*** This bug has been marked as a duplicate of 90576 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.