Closed Bug 294699 Opened 15 years ago Closed 14 years ago

Unable to click link or select text that is covered/overlapped by a positioned, transparent layer

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 102695

People

(Reporter: pachollini, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041220 K-Meleon/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041220 K-Meleon/0.9

See the attached URL.
The same behavior in Firefox 1.04, Firefox 1.0+ 20050517, K-meleon O.9 and
Mozilla Suite 1.4, 1.7.4, and 1.8b2 nightly build.
Works in MSIEs and Opera.
Not sure, wheater this is a bug according to CSS, but it feels weired for me as
user - its visible, it should be clickable and selectable.

Reproducible: Always

Steps to Reproduce:
1. Visit the page.
2. Try to click the link.
3. Try to select the text of the link.

Actual Results:  
Nothing.

Expected Results:  
Go to the page or select text.

Workaround wor the webmaster in this case is setting height of the containing
absolutely positioned element to 0.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
The problem here is that there's a "transparent layer" overlapping the text.
I've added a background-color to that layer to show this.

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Component: General → Layout
Product: Firefox → Core
Resolution: --- → DUPLICATE
Summary: Unable to click link or select text by a certain combination of relative and absolute positioning. → Unable to click link or select text that is covered/overlapped by a positioned, transparent layer
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.