BFCache does not work for pages loaded with Greasemonkey enabled

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
10 years ago

People

(Reporter: jaime.bugzilla, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050518
Firefox/1.0+ ID:2005051813

Set browser.sessionhistory.max_viewers = 10

Install GreaseMonkey from
http://ftp.iasi.roedu.net/mirrors/mozdev.org/greasemonkey/ version 0.3.4
Restart

With greasemonkey enabled visit some pages. Go back/forward - bfcache not used

Disable greasemonkey (click the taskbar icon) go to some pages, bfcache works
for these pages.

I can't see what greasemonkey might be setting that prevents the page being
loaded from bfcache although I'm not really sure what to look for.

This is probably invalid as greasemonkey is likely to be at fault, however it
may be an oversight in the bfcache implementation.
See http://bugzilla.mozdev.org/show_bug.cgi?id=10326 for the GM bug entry.

This bug should probably be marked Invalid, leaving open to catch possible dupes
until GM is (hopefully) fixed.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 3

13 years ago
Fixed in Greasemonkey 0.6.2.  Marking as INVALID because this was a bug in the
extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.