Closed Bug 294724 Opened 15 years ago Closed 15 years ago

Save Page As does not import CSS files called by @import rule

Categories

(Core Graveyard :: File Handling, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 126309

People

(Reporter: kabal, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

I went to http://www.alistapart.com/d/horizdropdowns/horizontal2.htm and wanted
to save the page with all associated files with the "Save Page as..." in the
File menu. However, the newly-created "horizontal2_files" directory did not
contain the external CSS file that is called in the following code in the <head>
section of the HTML document:
<style type="text/css">
@import "style2.css";
</style>

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.alistapart.com/d/horizdropdowns/horizontal2.htm
2. Select "Save Page as..." from File menu.
3. Save page with "Web page, complete" option selected.
4. Check for CSS file in "horizontal2_files" directory.

Actual Results:  
The CSS file that was called with the CSS @import rule was not included with the
other files (in this case, just one file - drop_down.js).

Expected Results:  
Any files called with the @import rule should be saved in the horizontal2_files
directory.

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Component: General → File Handling
Product: Firefox → Core
QA Contact: general → chrispetersen
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.