Closed Bug 294743 Opened 18 years ago Closed 18 years ago

unintended context menu appearance caused by left click

Categories

(Firefox :: Disability Access, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 107433

People

(Reporter: rintaro, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

holding down on left click causes the context menu to appear.

Reproducible: Always

Steps to Reproduce:
1. left click anywhere you can right click on and hold
Actual Results:  
context menu appears

Expected Results:  
no context menu

Mozilla and Firefox are virtually the only applications that do this. The  OS X
dock is another exception that also has this feature, but the dock's behaviour
is O.K./well-thought-out because:<ol>
<li>Clicking on an item in the context menu has the same effect as clicking on
the icon.</li>
<li>When a user clicks on a dock icon accidentally, the user can hold down and
get a context menu instead to prevent the click from unintendedly being
registered as a normal single click. Usually, the user can drag the mouse away
from the clicked spot before releasing the mouse button in order to prevent a
click from registering, however this on the dock can cause an icon to be dragged
and removed out of the dock, which users usually don't want to do.</li></ol>

This post may not be formatted properly because there is no preview button for
me to know.
That's normal behaviour. It was invented by Netscape in the 90's when they
wanted to simulate the right-click on a single-click mouse. That was befofe
Apple standardized on the ctrl-click as a replacement. We still support it for
backwards compatibility.

*** This bug has been marked as a duplicate of 117589 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
oops, other one
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 107433 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.