Note: There are a few cases of duplicates in user autocompletion which are being worked on.

layout breaks on text zoom

RESOLVED DUPLICATE of bug 4821

Status

()

Core
Layout: Block and Inline
--
enhancement
RESOLVED DUPLICATE of bug 4821
12 years ago
12 years ago

People

(Reporter: Dwain Alford, Unassigned)

Tracking

1.7 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

i was working on a page tonight helping someone on a list i belong  to when i
noticed a strange phenomenon.  i was zooming text in ie,  moz, ff, nn7.2,
nn8Beta and opera 8.

i had a negative margin set for a div to position it.  when i  zoomed the text,
the negative div broke the design (crawling up the  page) in all of the browsers
except opera 8.  the opera 8 page stayed  together and resized in relation to
all of the elements.  margins  appeared to remain the same instead of increasing
like in the other  browsers.

i would be glad to send you the files i was using when i discovered  this if you
would like.  you can run your own tests to see for  yourself.  i think that this
development is a positive step for  cross-browser and cross-platform standards.
 it would be wonderful  if we could eliminate hacks in the future by developing
products  that behaved the same.  sure this would mean that a "trade secret" 
becomes "public domain", but look at the benefit for the web  community and for
web designers; and for standards that we are all  striving to introduce and
implement.

Reproducible: Always

Steps to Reproduce:
1.zoom text several times or one large increment
2.
3.

Actual Results:  
the pix div with the negative margin crawled up the page and broke the design. 
the margins appeared to increased disproportionately.

Expected Results:  
the software should have held positions and margins and increased in size in
relation to the design resolution.

Comment 1

12 years ago
-> Layout: Block & Inline
Component: General → Layout: Block and Inline
Product: Firefox → Core
QA Contact: general → layout.block-and-inline
Version: unspecified → 1.7 Branch
For lack of specifics,

*** This bug has been marked as a duplicate of 4821 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.