Corrupt POST data from forms on pages encoded in UTF16 UTF32

RESOLVED DUPLICATE of bug 224820

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 224820
13 years ago
13 years ago

People

(Reporter: gammadelta, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl-PL; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When a page is encoded in UTF16 or UTF32 and has a form on it.
When i fill in the data, and send it, the stuff that gets sent is corrupted.
For instance a field named 'author' gets sent as 'a'
Only the first byte of the first character is taken, the rest is ignored.
If it's in little endian then 'a' gets sent, if it's in big endian then nothing.

In the end the data sent looks like this
a=&b=&c= or even like this =&=&=

Reproducible: Always

Steps to Reproduce:
1.Any page with a postable form in it, encoded in UTF16 or UTF32, byte order not
important
2.Post the form and Sniff the packets, or capture the sent data in other ways.


Actual Results:  
Sent data looked like this:
a=&n=

Expected Results:  
Sent data should look like this
author=value&name=othervalue

Comment 1

13 years ago
Is Bug 224820 your issue?

Comment 2

13 years ago
Looks exactly the same to me.

*** This bug has been marked as a duplicate of 224820 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

13 years ago
Yes it is the same. I searched but didn't find it.
You need to log in before you can comment on or make changes to this bug.