Cut Copy Paste only allowed once in URL Bar

VERIFIED DUPLICATE of bug 29004

Status

P3
normal
VERIFIED DUPLICATE of bug 29004
19 years ago
14 years ago

People

(Reporter: alan-lists, Assigned: don)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
2-27-00 (2000022708) build on Win95 

I can only do a cut, copy, or past once on the url bar.  After that the menu 
items are grayed out.  

Copy a url from Netscape's url bar
Past it into mozilla' url bar (Edit -> Paste)
then try and paste again the Cut, Copy, & Paste are all grayed out.

I can open another browser window and do a single cut, copy paste in the url bar 
then it is also grayed out.

As a side note right click on the URL bar is not emplimented for cut, copy, 
paste, ect.  I could not find a bugzilla bug for it.  Before I filed another bug 
on that wanted to see if someone was working on it.

This bug makes it hard to work in bugzilla verifying and confirming bugs as i 
copy test url's around in different moz windows.
I'm seeing either the same or a closely related bug; putting info in this report 
for now as the behavior is so close.

I don't see the precise same behavior of "works first time, grayed out 
thereafter," but on Commercial 2/28 on WinNT 4.0 SP4 (which reports itself, 
strangely, as Build ID 1999122808--I've filed bug 29527 on that), I am 
*sometimes* finding that the Edit-->Paste option is grayed out and I can't paste 
into the URL bar. 

However in my case, I can't identify a pattern to this. I can open a new window 
and paste two time without trouble. Yet if a window stays open for a long time 
(30-60 minutes), sometimes I discover that Edit-->Paste has become permanently 
grayed out and that CTRL-V also fails.
(Reporter)

Comment 2

19 years ago
ekrock, I am sometimes seeing that bug also, but it was was harder reproduce.  
When I found this bug i hopped it was close enough  :)
(Reporter)

Comment 3

19 years ago
I just saw that this bug may be a dupe of bug 29004 but not sure.  I will check 
on tomorrows build and mark it dupe if fixed.

CCing ekrock@netscape.com to check other related cases

Updated

19 years ago
QA Contact: paulmac → elig
(Reporter)

Comment 4

19 years ago
Yup, this bug looks like a dupe of bug 29004 that was fixed in today's build.
I am going mark it dupe as I was the original reporter.

ekrock, are you still seeing the odd cases you described that were close?




*** This bug has been marked as a duplicate of 29004 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
Verifying as duplicate. Thanks!
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.