Extension Update should backup and save the downloaded updates on the user's harddisk

RESOLVED DUPLICATE of bug 301849

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED DUPLICATE of bug 301849
13 years ago
9 years ago

People

(Reporter: Rastignac, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

FireFox Update checks for updates, downloads these updates and installs these
updates automatically. That's nice. But these updates are not saved at all. When
an user want to fully reinstall his FireFox (or install it on another computer),
he must download the whole things again and again because he don't have the
installation files stored somewhere.

So, FireFox Update should save all the downloaded ".xpi" and ".jar" files
somewhere. FireFox Update should ask the user "do you want to save these updates
? Yes/No" and then "where do you want to save these updates I found ?" (one file
per one file, or all at once). Or FireFox should have a default directory set in
the preferences (let's say a subdirectory in the FireFox installation directory,
named like "downloaded content" or "downloaded updates") and always backup and
save the new files there, without asking the user.

Each time I update a theme or an extension, I want to keep the
"example_1.2.3.xpi" somewhere. And the "example_1.2.4.xpi" a few days later. And
"example_1.3.0.xpi" a few weeks later. Then I can fully reinstall my FireFox
later, or install another computer with it, without having to download again and
again the same files. (All I have is a lousy V90/56k modem !). I want to backup
all the latest ".xpi" and ".jar" somewhere, so I always have the best up-to-date
files under my hand.

Thanks.

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
Can't you just make your own backups by downloading the .xpis and .jars and then
saving them to your hard disk yourself? To be honest, I don't see this feature
being implemented any time soon either...
This may be a little different from what's proposed, but maybe it would be
possible to create an "Export all configuration" option which allows the user to
export extensions, plugins and themes into a single xpi which can be then
installed into any other FF installation.
It's of course difficult to implement since there's versioning and OSs involved,
but it may be quite a useful tool.
(Reporter)

Comment 3

13 years ago
> Can't you just make your own backups by downloading
> the .xpis and .jars and then saving them to your
> hard disk yourself?

That's what I have been doing for monthes, and that's just PAINFULL !!! It takes
a lot of time, it takes a lot of manual steps, it's really painfull, and it
don't always work...
Why must I do manual operations by myself ? Computers and software are here to
automatically do this kind of repetitive tasks, aren't they ? I'm not a slave  ;)

Let's look at this monday morning's operations:
1) I launch FireFox Software Update.
2) FireFox finds seven updates (six extensions and one theme).
3) I write the list of the seven updates on a paper sheet (or I copy-paste the
screen's bitmap), then I cancel the FireFox Software Update window.
4) I open the Extension Manager.
5) I select the first extension of my list.
6) I choose "go to homepage".
7) I look for the updated extension to download it.
8) Sometimes, the homepage doesn't hold the latest version ! If the homepage has
not been updated for days, it still shows the previous version, not the lastest.
So I must search again and again where to find the latest version, or I must
come back a few days later.
9) When I find the latest version, I must save it to the harddisk (right click,
save as). Sometimes I can't (there's only a "click here to install" link on the
page that triggers the installation, and there's no direct link to the file
itself). So I must manage myself to download it (I don't want to install it, I
want to download it).
10) Sometimes, the extension has no version number in its name. It always saves
"example.xpi" and not "example_1.2.3.xpi". So I must manually append the version
number to the filename (to keep the history of the extension).
11) When it's done, I repeat steps 5 to 10 for each extension.
12) When it's done, I repeat steps 5 to 10 but for each theme.
13) Then, I install each extension and theme, one by one (drag&drop).
14) I restart Firefox.
15) I launch FireFox Software Update again, to be sure that's 100% OK. (All of
the updates are done ? All of the versions were the latest ? Etc).
16) I move all the downloaded ".xpi" and ".jar" in my "updates backup directory".
17) Then I sort this updates directory (I delete version "n-1" and I keep the
latest version "n").
18) I just lost a few minutes of my life.

FireFox should have automated most of these tasks:
- FireFox should save and backup the downloaded files somewhere.
- Or FireFox should display a "download it" button next to each line in the last
screen where all the updates are listed. So, if I want to install them, I just
click the "install now button" at the bottom of the screen (and all of them are
installed). And if I want to save one of them (or all of them), I can click on
the "download it" button in front of each listed item.

Thanks.
(Reporter)

Comment 4

13 years ago
What's the WORST problem of Microsoft's Windows Update ? It doesn't save
anything. It downloads a hell a lot of patches, It costs a hell a lot of
MegaBytes (it takes hours for my poor V90/56k modem), but nothing is saved,
nowhere, never.

So:
- When you want to reinstall your computer from scratch, you must download again
everything.
- When you want to upgrade more than one computer, you can't copy the patch from
the first computer to the others, because you don't have any file to copy. You
must download again everything.
- If you want to download the files to keep them, you must manage for yourself,
and that's long and painfull. (Launch MS's WU, note all of the patches it found,
then go and search these files by yourself one by one and save them on your
harddisk).

Mozilla Firefox's Software Update has the same big problem than MS's WU !! We
can do better than that, can't we ?

Thanks.

Comment 5

13 years ago
This bug still somewhat exists with the new update system being developed for
Firefox 1.5.  An advanced user could copy the update.mar file into the correct
location of a non-updated Firefox, create the update.status file appropriately,
and then launch Firefox.  This would work for a sufficiently advanced user.
(Reporter)

Comment 6

13 years ago
It seems that the extension "Mozilla_MR_Tech_Local_Install_3.1.0.xpi" can do
that (automatically backup downloaded extensions and themes somewhere on the
user's harddisk). I'm gonna try it.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
App update hasn't used xpi's or jar's for years and as far as having a copy of the app to install on other systems you should save the installer (e.g. windows), tar.bz2 (e.g. Linux), or dmg (e.g. Mac OS X) to accomplish this.

Resolving -> wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

10 years ago
This bug is about Extensions and Themes, not about Firefox itself. Comment #7 has it wrong. So, please, reopen this bug !

The aim of this bug is to have a backup of Extensions (XPIs) and Themes (JARs). We want an up-to-date backup somewhere. Each time Firefox updates an extension or a theme, it should refresh the backuped XPIs and JARs.
Status: RESOLVED → VERIFIED
Actually, the component you filed this bug under is application update so you filed it in the incorrect component. I'll reopen it and put it in Firefox -> General since the app update component can't help you here.
Status: VERIFIED → UNCONFIRMED
Component: Application Update → General
Product: Toolkit → Firefox
QA Contact: application.update → general
Resolution: WONTFIX → ---

Updated

10 years ago
Version: unspecified → Trunk
Actually, sounds more like it should be in Toolkt > Addon manager
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Summary: FireFox Update should backup and save the downloaded updates on the user's harddisk → Extension Update should backup and save the downloaded updates on the user's harddisk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301849
You need to log in before you can comment on or make changes to this bug.