Closed Bug 294920 Opened 15 years ago Closed 15 years ago

Right Click Context menu contains all options

Categories

(Core :: XPConnect, defect, blocker)

x86
Windows XP
defect
Not set
blocker

Tracking

()

RESOLVED FIXED

People

(Reporter: jaime.bugzilla, Assigned: dbradley)

References

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050520
Firefox/1.0+ ID:2005052007

Right click in window - erroneous options appear.
Regression from Bug 281988
*** Bug 294924 has been marked as a duplicate of this bug. ***
can someone add regression to the keywords, thanks
Flags: blocking1.8b2?
Caused by the 2nd half of the landing for bug 281988
Keywords: regression
Flags: blocking-aviary1.1?
Any messages in the JS console with the showInConsole pref set?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050520
Firefox/1.0+ ID:2005052007

JS Console messages on right click in blank areas of this page:

Error: gContextMenu has no properties
Source File: chrome://adblock/content/adblock.js
Line: 835

Error: cm has no properties
Source File: chrome://gcache/content/gcacheOverlay.js
Line: 31

Error: cm has no properties
Source File: chrome://bugmenot/content/bugmenotOverlay.js
Line: 981

Error: uncaught exception: [Exception... "Unexpected error"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://browser/content/browser.js :: anonymous :: line 4260"  data: no]
The "cleanup/fixup patch for various chrome files" patch in bug 281988 fixes this.
WFM now

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050520
Firefox/1.0+ ID:2005052010
Fixed by checkin of patch from comment 7.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Blocks: 281988
No longer depends on: 281988
I get this bug still under Mac OS X with
(Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050520
Also, none of the options in the contextual menu actully do anything.

I don't know if I should make a new bug for on the Mac.
*** Bug 295038 has been marked as a duplicate of this bug. ***
(In followup to comment #10)
Okay, it's fixed now in 20050521
Flags: blocking1.8b2?
Flags: blocking-aviary1.1?
It would be neat if this were actually an item which could be enabled to work
and be turned on if desired. ;-)
You need to log in before you can comment on or make changes to this bug.