middle-click on link gives autoscroll icon; does not open link

RESOLVED FIXED in mozilla1.8beta2

Status

()

RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: u88484, Assigned: bzbarsky)

Tracking

({regression})

Trunk
mozilla1.8beta2
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
When middle-clicking on a link the icon and scroll arrows for autoscroll appear
instead of opening the link in a new tab...regression
(Reporter)

Updated

14 years ago
Keywords: regression
Summary: middle-click on link gives autoscroll icon; does not open link → middle-click on link gives autoscroll icon; does not open link
Component: Tabbed Browser → Tabbed Browser
Depends on: 281988
Product: Firefox → Core
Component: Tabbed Browser → XPConnect

Comment 1

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050520
Firefox/1.0+

I can confirm this. Also Right-Click, then Open in new Tab doesn't work. I
expect this is related.
(Reporter)

Updated

14 years ago
Flags: blocking1.8b2?
*** Bug 294930 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Assignee: nobody → dbradley
Without autoscroll enabled, middle click functions as normal.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050520
Firefox/1.0+ ID:2005052009
(Assignee)

Updated

14 years ago
Blocks: 281988
No longer depends on: 281988
right click> open in new tab works for me. 14:41 build
This works for me with fixes checked in today, not yet in respins, for bug 281988.

/be
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Note: You have to have Tools > Options > Advanced > General > Use Auto-scroll
enabled to see the middle-clicking-a-link-not-working bug.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050520
Firefox/1.0+ ID:2005052013

Still broken, are there other fixes to go in or should this have been fixed in
this build.

Apologies if you meant that the fixes are still to be checked in.

-> Reopen in case it should be fixed by earlier checkins
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050520
Firefox/1.0+ ID:2005052014

With Tools > Options > Advanced > General > Use Auto-scroll ticked, middle
clicking on a link still pops the Auto-scroll icon rather than opening the link
in a new tab like it used to.
Yeah, fresh build from a 40 minute-old checkout shows the same thing here.

Comment 10

14 years ago
very annoying bug indeed.

Comment 11

14 years ago
FYI. Using All-In-One Gestures 0.14.3 with "All-In-One autoscroll" set, this
doesn't happen. With "Native autoscroll" set, problem manifests.

Comment 12

14 years ago
this hits linux too with the auto-scroll turned on
OS: Windows XP → All
(Assignee)

Comment 14

14 years ago
The problem is that instanceof is returning false across the board for
XPCNativeWrappers.

Comment 15

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050521
Firefox/1.0+

Still shows up on the 21st's build.
Created attachment 184193 [details]
xpcshell testcase showing instanceof working for "non-system" scripts

Need an easy way to test "system" scripts.  If someone can make a reduced
testcase for Firefox, please lay it on this bug.

/be
(Assignee)

Comment 17

14 years ago
Created attachment 184256 [details] [diff] [review]
"Minimal testcase"

Apply this, rebuild in browser/, start firefox, right-click on an HTML page.

instanceof isn't broken for Components.interfaces.nsIFoo because the relevant
hasInstance hook deals.

The problem here is that DOMJSClass_HasInstance does _not_ deal: it gets an
XPCNativeWrapper JSObject, gets its class, and tries to return a value based on
that, which naturally doesn't work.

I suppose we could manually get the wrapped JSObject here or something... Need
to expose a way to tell that we're dealing with an XPCNativeWrapper if we do
that.  And we might have to fix the various other hasInstance hooks too (eg
liveconnect,  maybe jsxml, etc).
(Assignee)

Comment 18

14 years ago
Created attachment 184266 [details] [diff] [review]
Patch per discussion with jst
Attachment #184266 - Flags: superreview?(jst)
Attachment #184266 - Flags: review?(jst)
Comment on attachment 184266 [details] [diff] [review]
Patch per discussion with jst

r+sr=jst
Attachment #184266 - Flags: superreview?(jst)
Attachment #184266 - Flags: superreview+
Attachment #184266 - Flags: review?(jst)
Attachment #184266 - Flags: review+
(Assignee)

Comment 20

14 years ago
Comment on attachment 184266 [details] [diff] [review]
Patch per discussion with jst

Fixes instanceof regression with the new security stuff.
Attachment #184266 - Flags: approval1.8b2?
(Assignee)

Updated

14 years ago
Assignee: dbradley → bzbarsky
Severity: critical → normal
Status: REOPENED → NEW
Target Milestone: --- → mozilla1.8beta2
(Assignee)

Comment 21

14 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Comment 22

14 years ago
(In reply to comment #21)
> Fixed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050522
Firefox/1.0+

Verified Fixed in the latest hourly on WinXP
*** Bug 294921 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking1.8b2?
You need to log in before you can comment on or make changes to this bug.