Error when downloading an empty subscription file

RESOLVED DUPLICATE of bug 231321

Status

Calendar
Internal Components
RESOLVED DUPLICATE of bug 231321
13 years ago
13 years ago

People

(Reporter: Josh, Assigned: shaver)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

If you have the checkbox set in the calendar preferences to automatically
publish your changes to a remote url, and delete all of your events, you can't
create any new events (because publish error when d/l the empty file) and anyone
subscribing to your calendar will get an error.  Sunbird needs to be able to
download a blank file as some people like to clean out their calendars.

Reproducible: Always

Steps to Reproduce:
1. Create your cal and enter a remote server url (I used file://).  Check the
box that automatically downloads/uploads your changes.

2. Try creating an event or task
Actual Results:  
This doesn't appear to be a valid file:  Here's what I got back from:
file://[whatever]
Result:

Expected Results:  
Nothing!  Having a blank calendar file should be fine.

This problem is simply an error anyone (subscriber or owner) tries to download a
blank .ICS file.

Comment 1

13 years ago
Josh:
   Thanks for the bug report.  This looks to me like it is the same issue that's
described in bug 231321.  Can you please take a look at that bug and see if you
agree that this report is a duplicate?  If so, please resolve it as such.
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 231321 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.