If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Doenload Manager: Removing large set of downloads is VERY slow and hangs Mozilla

RESOLVED DUPLICATE of bug 161783

Status

SeaMonkey
Download & File Handling
RESOLVED DUPLICATE of bug 161783
13 years ago
13 years ago

People

(Reporter: waxattack, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217 MultiZilla/1.7.0.2d
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217 MultiZilla/1.7.0.2d

Usecase:

User don't use Downloadmanager (it is disabled). But anyway download manager
saves all downloads (user just don't see that).

After 2-3 month user opens download manager and finds here 5000+ files (my
situation).

CTRL+A to select all downloads in the table. BUTTON "Remove from list".

1) Application hangs.
2) No Progress bars and the main browser window does not responds

As I see from HDD lights the problem is not in DELETE process. The problem might
be in:

1) Table component rebuilds
2) Some reports about EVERY deleted file in inner model (don't know the mozilla
structure)

Solutions:

1) I don't think it is necessery to store downloads in download manager IF user
has disabled it.

2) Implement progress bar

3) This process should run in separated from main browser thread

4) Something wrong with this code... simply run any stress test.

Thank you.

Reproducible: Always

Steps to Reproduce:
1. Put 10000+ files in the download manager
2. Select all files
3. Press Remove from List button
4. Note: I use Centrino 1.7 notebook. This process will be much faster on your
computers

Actual Results:  
Browser hangs for 10+ min. After that files are deleted.

Expected Results:  

1) I don't think it is necessery to store downloads in download manager IF user
has disabled it.

2) Implement progress bar

3) This process should run in separated from main browser thread

4) Something wrong with this code... simply run any stress test.

System:

ASUS notebook M5N (Centrino 1.7)

XP SP2

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 161783 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.