[xfe] selection forms not remembering their state

VERIFIED WONTFIX

Status

MozillaClassic
P3
normal
VERIFIED WONTFIX
20 years ago
19 years ago

People

(Reporter: Tomas Brodsky, Assigned: Chris McAfee)

Tracking

1998-04-08
Other
Other

Details

(Reporter)

Description

20 years ago
Created by Tomas Brodsky (brodsky@cfar.umd.edu) on Sunday, May 3, 1998 2:18:17 PM PDT
Additional Details :
When I open a page containing selection forms, make some
selections, then open another page and go back, the select
forms are reset to the default values.

The cause is probably in cmd/xfe/forms.c, function
select_create_widget, where the selected fields are
always initialized from the defaults.

forms.c, line 1651 in 1998-04-29 source:

     selected_p [i] = !!d2->def_selected;
     d2->selected = d2->def_selected;
(Assignee)

Comment 1

20 years ago
xfe is gone in the new world.
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WONTFIX

Updated

20 years ago
Status: RESOLVED → VERIFIED
Component: Platform: Rhapsody → XFE

Comment 2

20 years ago
Old bug...marking Verified...please use latest mozilla builds.
You need to log in before you can comment on or make changes to this bug.