Javascript console reports 2 uncaught exceptions when trying to use the bugzilla query page in 0520 Trunk. Impossible to use the query page, scripting possibly broken.

VERIFIED WORKSFORME

Status

()

Firefox
General
--
major
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Tristor, Unassigned)

Tracking

({qawanted})

Trunk
x86
Windows XP
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: regression?, URL)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050520
Firefox/1.0+

In the 0520 Trunk, when trying to use the Bugzilla query page, you are unable to
use it because clicking on products won't change the component list, and doing
anything in the form has no effect on the search.  Two uncaught exceptions are
shown on the JS Console:

Error: uncaught exception: Permission denied to get property
ChromeWindow.HTMLInputElement
Error: uncaught exception: Permission denied to get property
ChromeWindow.doOnSelectProduct

I am not sure what is causing this, and I don't know which component this
belongs in because I don't know where the problem actually lies.

Steps to Reproduce:

1. Goto https://bugzilla.mozilla.org/query.cgi
2. Click on any product or component
3. Glance at the JS Console

Expected Results:

Query form works, and no exceptions are reported.

Actual Results:

Unable to use the query form, 2 exceptions happen
(Reporter)

Comment 1

13 years ago
I am adding qawanted to see about getting a testcase for this.  I don't
understand the inner workings of everything well enough to know what is causing
this or to create a testcase for it (I sure wish I did, and maybe I will soon).
 I am going to find out which component/product this belongs in, since it
definitely isn't Firefox/General.
Keywords: qawanted
Whiteboard: regression?

Comment 2

13 years ago
Can no longer reproduce with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8b2) Gecko/20050520 Firefox/1.0+ ID:2005052022

Resolving WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050521
Firefox/1.0+

<-Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.