Last Comment Bug 295032 - l10n CVS account request: Norwegian Nynorsk (nn-NO) - Ronny Vårdal <ronnyva@gmail.com>
: l10n CVS account request: Norwegian Nynorsk (nn-NO) - Ronny Vårdal <ronnyva@g...
Status: RESOLVED FIXED
sshkey, voucher
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Marcia Knous [:marcia - use ni]
: Dave Miller [:justdave] (justdave@bugzilla.org)
Mentors:
Depends on:
Blocks: 293005
  Show dependency treegraph
 
Reported: 2005-05-21 06:13 PDT by Ronny Vårdal
Modified: 2008-03-07 12:53 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Public Key for Ronny Vårdal (680 bytes, text/plain)
2005-05-21 06:35 PDT, Ronny Vårdal
no flags Details
output of the compare script (16.39 KB, text/plain)
2005-06-23 03:41 PDT, Tim Maks van den Broek [:mad_maks]
no flags Details

Description Ronny Vårdal 2005-05-21 06:13:53 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nb-NO; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nb-NO; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

CVS Account Request for Ronny Vårdal, accountable for the nn-NO (Norwegian
Nynorsk) trunk to Firefox 1.1 and Thunderbird 1.1

Reproducible: Always

Steps to Reproduce:
Comment 1 Ronny Vårdal 2005-05-21 06:35:03 PDT
Created attachment 184177 [details]
Public Key for Ronny Vårdal

Generated on Windows XP with PuttyGen as 1024-bit SSH-2 DSA.
Comment 2 Marcia Knous [:marcia - use ni] 2005-06-01 17:30:33 PDT
Need the CVS Contributor form filled out - www.mozilla.org/hacking/form.html.
You have the SSH key, you will also need a voucher to post in the bug.  Thanks.
Comment 3 Ronny Vårdal 2005-06-02 03:44:17 PDT
Form was faxed a few days ago, and posted the same evening (around the last days
of May). Faxed to +1 650 903 0875 with ATT: on your name.
Comment 4 Ronny Vårdal 2005-06-02 05:04:38 PDT
Here is the CVS locale structure for nn-NO (Norwegian Nynorsk):

http://www.ramton.net/~ting/trunk-nn.zip (primary site)
http://my.floppy.no/trunk-nn.zip (secondary mirror)
Comment 5 Tim Maks van den Broek [:mad_maks] 2005-06-23 03:41:32 PDT
Created attachment 187114 [details]
output of the compare script

There are a lot of missing entities (most of them are added in the last week,
so that is not your fault).

browser/defines.inc = ok
browser/extra-jar.mn = ok (personaly i would put the help images in a images
dir like the most other locales did)
browser/readme.txt = ok
bookmarks.html = ok ( http://www.mozilla.org/products/firefox/central.html
needs to be localized, see http://wiki.mozilla.org/L10n:Firefox_Extras)

please update your zipfile and then i can review your locale positive.
Comment 6 Ronny Vårdal 2005-07-04 05:36:59 PDT
Updated both zip files, so no matter what mirror you use - it should be the same.
Also taken your other files into consideration.. both Start Pages l10n
(central.html) and Start-snippits (firefox:extra). Respective emails will get
their emails when done.

Happy with the contens of the zip now?
Comment 7 Håvard Mork 2005-07-09 08:25:22 PDT
nn-NO commmitted to cvs.mozilla.org:/l10n at 17:08 CEST.

No missing entities, no errors found. Some parts are imported from the similar
locale nb-NO.

If it is permitted for an other locale's owner (nb-NO, me) to vouch for a CVS
account request to another module owner, then I am vouching for Ronny's l10n CVS
access.
Comment 8 Axel Hecht 2005-07-09 09:18:21 PDT
THERE IS NO POSITIVE REVIEW OF THIS LOCALE!

Havard, care about your locale, do NOT CHECK IN STUFF in other locales, EVER!

Note that the registration of nn-NO hasn't been done yet, either. Thus, none
of those that could vouch (bsmedberg, gandalf, me) vouched here.

Havard, this is a very dark-yellow card for you.
Comment 9 Zibi Braniecki [:gandalf][:zibi] 2005-07-26 07:41:24 PDT
Sorry for delay.

Review:
1) You must remove all CVS directories and files
2) Why do you have LOCALE_HAS_HELP_IMAGES ? It's not used anywhere
3) Did Rebron accepted this searchengines set? If no, than you must switch it to
default set or get approval from him.
4) Same about bookmarks. 
5) Why do you have so many help images comparing to other trunk locales? (it's
just a question, it might be a proper situation)

I don't have compare-locales script here, so I assume you checked against it.
The rest is ok. I'm ok with this locale's quality with minor issues mentioned above.
Comment 10 Axel Hecht 2005-08-02 07:25:28 PDT
(In reply to comment #9)
> Sorry for delay.
> 
> Review:
> 1) You must remove all CVS directories and files
void, the locale is in CVS, that's why we have those dirs (don't copy this
elsewhere)
> 2) Why do you have LOCALE_HAS_HELP_IMAGES ? It's not used anywhere
should be removed
> 3) Did Rebron accepted this searchengines set? If no, than you must switch it to
> default set or get approval from him.
> 4) Same about bookmarks. 
needs a new bug
> 5) Why do you have so many help images comparing to other trunk locales? (it's
> just a question, it might be a proper situation)

This is 31 pics, 30 of them in extra-jar.mn, which needs to be fixed.
en-US has 10 screenshots, see 
http://cvs-www.mozilla.org/webtools/bonsai/rview.cgi?dir=mozilla-org%2Fhtml%2Fprojects%2Ffirefox%2Fhelp%2F1.1&rev=&module=default&cvsroot=%2Fcvsroot
(it took me 10 minutes to find those, thanks to the crap design of this), so
maybe a few of those are too many?

Comment 11 Axel Hecht 2005-09-07 07:34:34 PDT
Ting filed bug 307352 to handle the trademark issues, the remaining fixes can land
with bugs as ting prefers, no further blockage.

Marcia, if you have the form in your files, this is ready to go from my point.

Vouching, finally! Sorry for the confusion, blood, sweat and teers.
Comment 12 Ronny Vårdal 2005-10-03 09:35:38 PDT
If I now have what I need, what is then holding this back?
Comment 13 Marcia Knous [:marcia - use ni] 2005-10-05 18:13:18 PDT
Sorry, we just moved and I need to find my file folder with CVS forms. Since
this has bitrotted so long, I am going to have justdave create this account and
hunt for the form it the meantime. Apologies for the delay.
Comment 14 Dave Miller [:justdave] (justdave@bugzilla.org) 2005-10-05 21:05:47 PDT
Account created.  Your CVSROOT should be:

    ronny%firefox.no@cvs.mozilla.org:/l10n

Don't forget to set the CVS_RSH environment variable to 'ssh'.

If you have any problems connecting, let me know.

Leaving the bug open pending Marcia finding your form...
Comment 15 Pavel Franc - Mozilla.cz 2005-10-30 17:13:02 PST
> Leaving the bug open pending Marcia finding your form...

Marcia could we mark this as FIXED?
Comment 16 Marcia Knous [:marcia - use ni] 2006-07-03 14:31:09 PDT
I will have to hunt through my CVS forms since it has been some time since I said I would look, but I actually didn't. If I can't find the form I will contact him for another one.
Comment 17 Ronny Vårdal 2007-03-20 12:59:51 PDT
Why isn't this FIXED? Still not found my form Marcia? Updating my wiki-profile to say CVS: YES :-)
Comment 18 Marcia Knous [:marcia - use ni] 2007-03-20 15:14:15 PDT
Ronny: Sorry for not following thru on this bug. I cannot locate the form. If you would be kind enough to email the form to me, I will close this one out.
Comment 19 Marcia Knous [:marcia - use ni] 2007-03-22 11:55:14 PDT
closing this out, received the form via fax today. Thanks for the followup.
Comment 20 Ronny Vårdal 2008-03-07 12:53:05 PST
Edited email address in title

Note You need to log in before you can comment on or make changes to this bug.