The default bug view has changed. See this FAQ.

Request: dragging link over new tab/new window button opens in new tab/window

VERIFIED DUPLICATE of bug 179845

Status

()

Core
Drag and Drop
--
enhancement
VERIFIED DUPLICATE of bug 179845
12 years ago
12 years ago

People

(Reporter: Bruce Boughton, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When dragging an URL from another application (or from within Mozilla) to open
it, if the user has the new tab and/or new window buttons displayed on their
toolbar, they should be able to drop the link onto these to open in a new tab or
a new window. This would be useful for users whose tab bar is hidden when only
one tab is open (the default).

Reproducible: Always

Steps to Reproduce:
1. Drag a link from somewhere (I dragged an URL from an email in Thunderbird)
2. Try to drop it on the new tab/new window button
3. The cursor changes to a circle with a bar through it indicating an illegal
operation

Actual Results:  
Nothing!

Expected Results:  
The software should have loaded the URL in a new tab if it was dropped on the
new tab button or a new window if it was dropped on the new window button.

Comment 1

12 years ago
This looks like it would be a neat idea.  I could possibly see some problems
with implementing it, but we will see.

<-NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Request: dragging link over new tab/new window button opens in new tab/window → Request: draggingnew tab/new window button opens in new tab/window link over
(Reporter)

Updated

12 years ago
Summary: Request: draggingnew tab/new window button opens in new tab/window link over → Request: dragging link over new tab/new window button opens in new tab/window

Comment 2

12 years ago
Duplicate of Firefox bug 179845?

Comment 3

12 years ago
(In reply to comment #2)
> Duplicate of Firefox bug 179845?

Looks like it, don't know how I missed that.



*** This bug has been marked as a duplicate of 179845 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.